User account creation filtered due to spam.

Bug 10140 - Cross-compiling gcc 3.3 for sh-elf: gnu-regex.c:undefined reference to: ___mempcpy
Summary: Cross-compiling gcc 3.3 for sh-elf: gnu-regex.c:undefined reference to: ___me...
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: bootstrap (show other bugs)
Version: 3.3
: P3 normal
Target Milestone: ---
Assignee: Not yet assigned to anyone
URL:
Keywords:
: 10636 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-03-18 20:26 UTC by areuwho
Modified: 2003-10-29 01:36 UTC (History)
4 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description areuwho 2003-03-18 20:26:00 UTC
I'm having trouble cross-compiling the newest gcc-snapshot for the sh-elf (dreamcast) target. Here's my configure:

In the BUILD-GCC directory:

../gcc-20030317/configure --target=sh-elf --prefix=/usr/local/dc --without-headers --with-newlib --enable-languages=c

after typing make all, it gives me this output after compiling various things:

make[2]: Entering directory `/gcc/build-gcc/gcc/fixinc'
gcc -DIN_GCC -DHAVE_CONFIG_H -g -O2 -DIN_GCC -DCROSS_COMPILE -W -Wall -Wwrit
e-strings -Wstrict-prototypes -Wmissing-prototypes -Wtraditional -pedantic -
Wno-long -long -DHAVE_CONFIG_H -DGENERATOR_FILE  -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wtraditional -pedantic -Wno-long-long  -I. -I.. -I../../../gcc-20030317/gcc/fixinc -I../../../gcc-20030317/gcc/fixinc/.. -I../../../gcc-20030317/gcc/fixinc/../config -I../../../gcc-2003031
7/gcc/fixinc/../../include  -o fixincl.exe fixincl.o fixtests.o fixfixes.o server.o procopen.o gnu-regex.o fixlib.o ../../libiberty/libiberty.a
gnu-regex.o(.text+0x6556): In function `regerror':
/gcc/build-gcc/gcc/fixinc/../../../gcc-20030317/gcc/fixinc/gnu-regex.c:5723:undefined reference to `___mempcpy'
collect2: ld returned 1 exit status
make[2]: *** [full-stamp] Error 1
make[2]: Leaving directory `/gcc/build-gcc/gcc/fixinc'
make[1]: *** [fixinc.sh] Error 2
make[1]: Leaving directory `/gcc/build-gcc/gcc'
make: *** [all-gcc] Error 2

I also successfully compiled the binutils (2.13.2.1) for the sh-elf target

I was following the tutorial on
http://www.hangar-eleven.de/en/devdc-index.html , except I replaced binutils-2.11.2 with version 2.13.2.1 and gcc-3.0.4 with gcc-3.3 (snapshot 20030317)

Release:
gcc-3.3 (snapshot 20030317)

Environment:
linux-2.4.19, host binutils 2.13.2.1, host gcc 2.95.2 (also tried with 3.3)

How-To-Repeat:
reply to paras DOT rasmatazz AT gmx DOT net please
Comment 1 paras.rasmatazz 2003-03-19 13:46:55 UTC
From: "Paras Rasmatazz" <paras.rasmatazz@gmx.net>
To: <gcc-gnats@gcc.gnu.org>,
	<areuwho@freenet.de>,
	<gcc-bugs@gcc.gnu.org>,
	<nobody@gcc.gnu.org>,
	<gcc-prs@gcc.gnu.org>
Cc:  
Subject: Re: bootstrap/10140: Cross-compiling gcc 3.3 for sh-elf: gnu-regex.c:undefined reference to: ___mempcpy
Date: Wed, 19 Mar 2003 13:46:55 +0100

 This is a multi-part message in MIME format.
 
 ------=_NextPart_000_0003_01C2EE1E.00D5DB00
 Content-Type: text/plain;
 	charset="iso-8859-1"
 Content-Transfer-Encoding: quoted-printable
 
 
 http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=3Dview%20audit-trail&database=3D=
 gcc&pr=3D10140
 ------=_NextPart_000_0003_01C2EE1E.00D5DB00
 Content-Type: text/html;
 	charset="iso-8859-1"
 Content-Transfer-Encoding: quoted-printable
 
 <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
 <HTML><HEAD>
 <META http-equiv=3DContent-Type content=3D"text/html; =
 charset=3Diso-8859-1">
 <META content=3D"MSHTML 6.00.2800.1141" name=3DGENERATOR>
 <STYLE></STYLE>
 </HEAD>
 <BODY bgColor=3D#ffffff>
 <DIV>&nbsp;</DIV><A=20
 href=3D"http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=3Dview%20audit-trail&a=
 mp;database=3Dgcc&amp;pr=3D10140">http://gcc.gnu.org/cgi-bin/gnatsweb.pl?=
 cmd=3Dview%20audit-trail&amp;database=3Dgcc&amp;pr=3D10140</A></BODY></HT=
 ML>
 
 ------=_NextPart_000_0003_01C2EE1E.00D5DB00--
 

Comment 2 Kaveh Ghazi 2003-04-15 14:24:26 UTC
From: ghazi@gcc.gnu.org
To: gcc-gnats@gcc.gnu.org
Cc:  
Subject: bootstrap/10140
Date: 15 Apr 2003 14:24:26 -0000

 CVSROOT:	/cvs/gcc
 Module name:	gcc
 Changes by:	ghazi@gcc.gnu.org	2003-04-15 14:24:26
 
 Modified files:
 	gcc            : ChangeLog 
 	libiberty      : ChangeLog getopt.c regex.c 
 	gcc/fixinc     : gnu-regex.c 
 
 Log message:
 	gcc:
 	PR target/10338
 	PR bootstrap/10198
 	PR bootstrap/10140
 	* fixinc/gnu-regex.c (regerror): Use mempcpy not __mempcpy.
 	
 	libiberty:
 	PR target/10338
 	PR bootstrap/10198
 	PR bootstrap/10140
 	* getopt.c (exchange, _getopt_initialize): Use mempcpy not
 	__mempcpy.
 	* regex.c (regerror): Likewise.
 
 Patches:
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ChangeLog.diff?cvsroot=gcc&r1=1.17456&r2=1.17457
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libiberty/ChangeLog.diff?cvsroot=gcc&r1=1.431&r2=1.432
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libiberty/getopt.c.diff?cvsroot=gcc&r1=1.7&r2=1.8
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libiberty/regex.c.diff?cvsroot=gcc&r1=1.13&r2=1.14
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/fixinc/gnu-regex.c.diff?cvsroot=gcc&r1=1.15&r2=1.16
 

Comment 3 Kaveh Ghazi 2003-04-15 14:24:26 UTC
From: ghazi@gcc.gnu.org
To: gcc-gnats@gcc.gnu.org
Cc:  
Subject: bootstrap/10140
Date: 15 Apr 2003 14:24:26 -0000

 CVSROOT:	/cvs/gcc
 Module name:	gcc
 Changes by:	ghazi@gcc.gnu.org	2003-04-15 14:24:26
 
 Modified files:
 	gcc            : ChangeLog 
 	libiberty      : ChangeLog getopt.c regex.c 
 	gcc/fixinc     : gnu-regex.c 
 
 Log message:
 	gcc:
 	PR target/10338
 	PR bootstrap/10198
 	PR bootstrap/10140
 	* fixinc/gnu-regex.c (regerror): Use mempcpy not __mempcpy.
 	
 	libiberty:
 	PR target/10338
 	PR bootstrap/10198
 	PR bootstrap/10140
 	* getopt.c (exchange, _getopt_initialize): Use mempcpy not
 	__mempcpy.
 	* regex.c (regerror): Likewise.
 
 Patches:
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ChangeLog.diff?cvsroot=gcc&r1=1.17456&r2=1.17457
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libiberty/ChangeLog.diff?cvsroot=gcc&r1=1.431&r2=1.432
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libiberty/getopt.c.diff?cvsroot=gcc&r1=1.7&r2=1.8
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/libiberty/regex.c.diff?cvsroot=gcc&r1=1.13&r2=1.14
 http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/fixinc/gnu-regex.c.diff?cvsroot=gcc&r1=1.15&r2=1.16
 

Comment 6 Kaveh Ghazi 2003-04-25 15:17:10 UTC
State-Changed-From-To: open->closed
State-Changed-Why: Fixed in 3.3, too late for 3.2.3.
Comment 7 Giovanni Bajo 2003-06-09 18:07:40 UTC
*** Bug 10636 has been marked as a duplicate of this bug. ***