Bug 100379 - cyclades.h is removed from linux kernel header files
Summary: cyclades.h is removed from linux kernel header files
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: sanitizer (show other bugs)
Version: 12.0
: P3 normal
Target Milestone: 9.4
Assignee: Not yet assigned to anyone
URL:
Keywords:
: 100691 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-05-02 00:21 UTC by cqwrteur
Modified: 2021-09-17 06:36 UTC (History)
9 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed: 2021-05-07 00:00:00


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cqwrteur 2021-05-02 00:21:49 UTC
https://lkml.org/lkml/2021/3/2/153

../../../../../../gcc/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cpp:134:10: fatal error: linux/cyclades.h: No such file or directory
  134 | #include <linux/cyclades.h>
      |          ^~~~~~~~~~~~~~~~~~
compilation terminated.
Comment 1 Andrew Pinski 2021-05-02 02:17:12 UTC
Please also report this upstream.
Comment 2 vvinayag 2021-05-05 12:46:22 UTC
I can confirm that the missing linux/cyclades.h is breaking cross builds:
Build: x86_64 (Linux)
Host:  x86_64 (Linux)
Target: arm-none-linux-gnueabihf / arm-none-linux-gnueabi / aarch64_be-none-linux-gnu / aarch64-none-linux-gnu
Comment 3 Tamar Christina 2021-05-07 09:39:35 UTC
Submit LLVM patch, once accepted can backport here https://reviews.llvm.org/D102059
Comment 4 Andrew Pinski 2021-05-20 05:54:29 UTC
*** Bug 100691 has been marked as a duplicate of this bug. ***
Comment 5 CVS Commits 2021-05-21 09:31:38 UTC
The master branch has been updated by Tamar Christina <tnfchris@gcc.gnu.org>:

https://gcc.gnu.org/g:745dae5923aba02982563481d75a21595df22ff8

commit r12-971-g745dae5923aba02982563481d75a21595df22ff8
Author: Tamar Christina <tamar.christina@arm.com>
Date:   Fri May 21 10:30:59 2021 +0100

    libsanitizer: Remove cyclades from libsanitizer
    
    The Linux kernel has removed the interface to cyclades from
    the latest kernel headers[1] due to them being orphaned for the
    past 13 years.
    
    libsanitizer uses this header when compiling against glibc, but
    glibcs itself doesn't seem to have any references to cyclades.
    
    Further more it seems that the driver is broken in the kernel and
    the firmware doesn't seem to be available anymore.
    
    As such since this is breaking the build of libsanitizer (and so the
    GCC bootstrap[2]) I propose to remove this.
    
    [1] https://lkml.org/lkml/2021/3/2/153
    [2] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=100379
    
    (cherry picked from commit f7c5351552387bd43f6ca3631016d7f0dfe0f135)
    
    libsanitizer/ChangeLog:
    
            PR sanitizer/100379
            * sanitizer_common/sanitizer_common_interceptors_ioctl.inc: Cherry-pick
            llvm-project revision f7c5351552387bd43f6ca3631016d7f0dfe0f135.
            * sanitizer_common/sanitizer_platform_limits_posix.cpp: Likewise.
            * sanitizer_common/sanitizer_platform_limits_posix.h: Likewise.
Comment 6 CVS Commits 2021-05-21 09:36:08 UTC
The releases/gcc-11 branch has been updated by Tamar Christina <tnfchris@gcc.gnu.org>:

https://gcc.gnu.org/g:2bf34b9f4e446bf9be7f04458058dd5319fb396e

commit r11-8455-g2bf34b9f4e446bf9be7f04458058dd5319fb396e
Author: Tamar Christina <tamar.christina@arm.com>
Date:   Fri May 21 10:30:59 2021 +0100

    libsanitizer: Remove cyclades from libsanitizer
    
    The Linux kernel has removed the interface to cyclades from
    the latest kernel headers[1] due to them being orphaned for the
    past 13 years.
    
    libsanitizer uses this header when compiling against glibc, but
    glibcs itself doesn't seem to have any references to cyclades.
    
    Further more it seems that the driver is broken in the kernel and
    the firmware doesn't seem to be available anymore.
    
    As such since this is breaking the build of libsanitizer (and so the
    GCC bootstrap[2]) I propose to remove this.
    
    [1] https://lkml.org/lkml/2021/3/2/153
    [2] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=100379
    
    libsanitizer/ChangeLog:
    
            PR sanitizer/100379
            * sanitizer_common/sanitizer_common_interceptors_ioctl.inc: Cherry-pick
            llvm-project revision f7c5351552387bd43f6ca3631016d7f0dfe0f135.
            * sanitizer_common/sanitizer_platform_limits_posix.cpp: Likewise.
            * sanitizer_common/sanitizer_platform_limits_posix.h: Likewise.
    
    (cherry picked from commit 745dae5923aba02982563481d75a21595df22ff8)
Comment 7 CVS Commits 2021-05-21 09:40:37 UTC
The releases/gcc-10 branch has been updated by Tamar Christina <tnfchris@gcc.gnu.org>:

https://gcc.gnu.org/g:a7e72b282177fbaa6a852324641c871313d326da

commit r10-9862-ga7e72b282177fbaa6a852324641c871313d326da
Author: Tamar Christina <tamar.christina@arm.com>
Date:   Fri May 21 10:30:59 2021 +0100

    libsanitizer: Remove cyclades from libsanitizer
    
    The Linux kernel has removed the interface to cyclades from
    the latest kernel headers[1] due to them being orphaned for the
    past 13 years.
    
    libsanitizer uses this header when compiling against glibc, but
    glibcs itself doesn't seem to have any references to cyclades.
    
    Further more it seems that the driver is broken in the kernel and
    the firmware doesn't seem to be available anymore.
    
    As such since this is breaking the build of libsanitizer (and so the
    GCC bootstrap[2]) I propose to remove this.
    
    [1] https://lkml.org/lkml/2021/3/2/153
    [2] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=100379
    
    libsanitizer/ChangeLog:
    
            PR sanitizer/100379
            * sanitizer_common/sanitizer_common_interceptors_ioctl.inc: Cherry-pick
            llvm-project revision f7c5351552387bd43f6ca3631016d7f0dfe0f135.
            * sanitizer_common/sanitizer_platform_limits_posix.cpp: Likewise.
            * sanitizer_common/sanitizer_platform_limits_posix.h: Likewise.
    
    (cherry picked from commit 745dae5923aba02982563481d75a21595df22ff8)
Comment 8 CVS Commits 2021-05-21 11:17:45 UTC
The releases/gcc-9 branch has been updated by Tamar Christina <tnfchris@gcc.gnu.org>:

https://gcc.gnu.org/g:2b40941d23b1570cdd90083b58fa0f66aa58c86e

commit r9-9546-g2b40941d23b1570cdd90083b58fa0f66aa58c86e
Author: Tamar Christina <tamar.christina@arm.com>
Date:   Fri May 21 12:16:56 2021 +0100

    libsanitizer: Remove cyclades from libsanitizer
    
    The Linux kernel has removed the interface to cyclades from
    the latest kernel headers[1] due to them being orphaned for the
    past 13 years.
    
    libsanitizer uses this header when compiling against glibc, but
    glibcs itself doesn't seem to have any references to cyclades.
    
    Further more it seems that the driver is broken in the kernel and
    the firmware doesn't seem to be available anymore.
    
    As such since this is breaking the build of libsanitizer (and so the
    GCC bootstrap[2]) I propose to remove this.
    
    [1] https://lkml.org/lkml/2021/3/2/153
    [2] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=100379
    
    libsanitizer/ChangeLog:
    
            PR sanitizer/100379
            * sanitizer_common/sanitizer_common_interceptors_ioctl.inc: Cherry-pick
            llvm-project revision f7c5351552387bd43f6ca3631016d7f0dfe0f135.
            * sanitizer_common/sanitizer_platform_limits_posix.cc: Likewise.
            * sanitizer_common/sanitizer_platform_limits_posix.h: Likewise.
Comment 9 Tamar Christina 2021-05-21 11:19:40 UTC
Fixed on master and all open branches.