Bug 1 - Test of new GCC GNATS db.
Summary: Test of new GCC GNATS db.
Status: RESOLVED FIXED
Alias: None
Product: gcc
Classification: Unclassified
Component: other (show other bugs)
Version: unknown
: P3 normal
Target Milestone: 3.0.x
Assignee: Not yet assigned to anyone
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 1999-08-03 19:56 UTC by crash
Modified: 2020-04-01 09:58 UTC (History)
2 users (show)

See Also:
Host:
Target:
Build:
Known to work:
Known to fail:
Last reconfirmed:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description crash 1999-08-03 19:56:00 UTC
Just a test to make sure it's all set up right.

Now, some further test.

Release:
1.0
Comment 1 Joseph S. Myers 1999-08-03 20:02:54 UTC
State-Changed-From-To: open->closed
State-Changed-Why: Test worked.
Comment 2 Joseph S. Myers 1999-10-08 21:53:55 UTC
From: Jason Molenda <jsm@cygnus.com>
To: java-gnats@sourceware.cygnus.com
Cc:  
Subject: Re: java/1
Date: Fri, 8 Oct 1999 21:53:55 -0700

 >Number:         66
 >Category:       java
 >Synopsis:       Re: java/1
 >Confidential:   yes
 >Severity:       serious
 >Priority:       medium
 >Responsible:    jsm
 >State:          closed
 >Class:          sw-bug
 >Submitter-Id:   net
 >Arrival-Date:   Fri Oct 08 22:00:00 PDT 1999
 >Closed-Date:    Fri Oct 08 22:16:52 PDT 1999
 >Last-Modified:  Fri Oct 08 22:16:52 PDT 1999
 >Originator:     
 >Release:        
 >Organization:
 >Environment:
 >Description:
  Test follow-up to see what happens.
 >How-To-Repeat:
 >Fix:
 >Release-Note:
 >Audit-Trail:
 
 Formerly PR gcj/66
 
 Responsible-Changed-From-To: green->jsm 
 Responsible-Changed-By: root 
 Responsible-Changed-When: Fri Oct 8 22:12:44 PDT 1999 
 Responsible-Changed-Why:  
 This is a test. 
 
 
 From: Jason Molenda <jsm@cygnus.com>
 To: java-gnats@sourceware.cygnus.com
 Cc:  
 Subject: Re: gcj/66
 Date: Fri, 8 Oct 1999 22:15:07 -0700
 
  A test follow-up to this PR.
  
 State-Changed-From-To: open->closed 
 State-Changed-By: jsm 
 State-Changed-When: Fri Oct 8 22:16:45 PDT 1999 
 State-Changed-Why:  
 Done. 
 . 
 
 >Unformatted:
Comment 3 CVS Commits 2003-07-02 09:36:25 UTC
Subject: Bug 1

CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	nathan@gcc.gnu.org	2003-07-02 09:36:20

Modified files:
	gcc/cp         : ChangeLog decl2.c typeck.c 
	gcc/testsuite  : ChangeLog 
Added files:
	gcc/testsuite/g++.dg/template: dependent-expr1.C 

Log message:
	cp:
	PR c++/9779
	* decl2.c (arg_assoc_class): Don't die on NULL type.
	* typeck.c (type_unknown_p): Don't die on untyped expressions.
	testsuite:
	PR c++/9779
	* g++.dg/template/dependent-expr1.C: New.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/cp/ChangeLog.diff?cvsroot=gcc&r1=1.3481&r2=1.3482
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/cp/decl2.c.diff?cvsroot=gcc&r1=1.635&r2=1.636
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/cp/typeck.c.diff?cvsroot=gcc&r1=1.469&r2=1.470
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/ChangeLog.diff?cvsroot=gcc&r1=1.2826&r2=1.2827
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/testsuite/g++.dg/template/dependent-expr1.C.diff?cvsroot=gcc&r1=NONE&r2=1.1

Comment 4 CVS Commits 2020-04-01 00:17:10 UTC
The master branch has been updated by GCC Administrator <gccadmin@gcc.gnu.org>:

https://gcc.gnu.org/g:73dd051894b8293d35ea1c436fa408c404b80813

commit r10-7488-g73dd051894b8293d35ea1c436fa408c404b80813
Author: GCC Administrator <gccadmin@gcc.gnu.org>
Date:   Wed Apr 1 00:16:38 2020 +0000

    Daily bump.
Comment 5 CVS Commits 2020-04-01 00:17:42 UTC
The releases/gcc-8 branch has been updated by GCC Administrator <gccadmin@gcc.gnu.org>:

https://gcc.gnu.org/g:bfdb0a856a157dadfa127b77ac794d0d175c18c4

commit r8-10155-gbfdb0a856a157dadfa127b77ac794d0d175c18c4
Author: GCC Administrator <gccadmin@gcc.gnu.org>
Date:   Wed Apr 1 00:17:16 2020 +0000

    Daily bump.
Comment 6 CVS Commits 2020-04-01 00:18:15 UTC
The releases/gcc-9 branch has been updated by GCC Administrator <gccadmin@gcc.gnu.org>:

https://gcc.gnu.org/g:2594e9a069698d99ac5a012f3189288e19a5094b

commit r9-8428-g2594e9a069698d99ac5a012f3189288e19a5094b
Author: GCC Administrator <gccadmin@gcc.gnu.org>
Date:   Wed Apr 1 00:17:49 2020 +0000

    Daily bump.
Comment 7 CVS Commits 2020-04-01 07:37:55 UTC
The master branch has been updated by Martin Liska <marxin@gcc.gnu.org>:

https://gcc.gnu.org/g:142d68f50b48309f48e34fc1d9d6dbbeecfde684

commit r10-7492-g142d68f50b48309f48e34fc1d9d6dbbeecfde684
Author: Martin Liska <mliska@suse.cz>
Date:   Wed Apr 1 09:37:37 2020 +0200

    Fix typo in a macro usage.
    
            PR lto/94249
            * plugin-api.h: Fix a typo.
Comment 8 CVS Commits 2020-04-01 07:45:49 UTC
The master branch has been updated by Jakub Jelinek <jakub@gcc.gnu.org>:

https://gcc.gnu.org/g:9ecb3ecc8cc0497a2cc815589c59547fd5af8512

commit r10-7493-g9ecb3ecc8cc0497a2cc815589c59547fd5af8512
Author: Jakub Jelinek <jakub@redhat.com>
Date:   Wed Apr 1 09:44:59 2020 +0200

    objsz: Don't call replace_uses_by on SSA_NAME_OCCURS_IN_ABNORMAL_PHI [PR94423]
    
    The following testcase ICEs because the objsz pass calls replace_uses_by
    on SSA_NAME_OCCURS_IN_ABNORMAL_PHI SSA_NAME.  The following patch instead
    of that calls replace_call_with_value, which will turn it into
      xyz_123(ab) = 234;
    
    2020-04-01  Jakub Jelinek  <jakub@redhat.com>
    
            PR middle-end/94423
            * tree-object-size.c (pass_object_sizes::execute): Don't call
            replace_uses_by for SSA_NAME_OCCURS_IN_ABNORMAL_PHI lhs, instead
            call replace_call_with_value.
    
            * gcc.dg/ubsan/pr94423.c: New test.
Comment 9 CVS Commits 2020-04-01 09:58:55 UTC
The master branch has been updated by Martin Liska <marxin@gcc.gnu.org>:

https://gcc.gnu.org/g:d3ee88fdb4e0f718aaba050a3eb7174b8934a29d

commit r10-7494-gd3ee88fdb4e0f718aaba050a3eb7174b8934a29d
Author: Martin Liska <mliska@suse.cz>
Date:   Wed Apr 1 11:58:35 2020 +0200

    Clear me from patch ownership.