Bug 60349

Summary: Any call to expq (or libquadmath function that might possibly call expq) segfaults in mingw-gcc.
Product: gcc Reporter: John Maddock <john>
Component: libquadmathAssignee: Not yet assigned to anyone <unassigned>
Status: RESOLVED INVALID    
Severity: blocker CC: fxcoudert
Priority: P3    
Version: 4.8.1   
Target Milestone: ---   
Host: Target:
Build: Known to work:
Known to fail: Last reconfirmed: 2014-02-27 00:00:00

Description John Maddock 2014-02-26 19:27:57 UTC
This effects gcc-4.8.1 and 4.8.2 (at least), on both mingw32 and mingw64, the following program segfaults:


#include <quadmath.h>

int main()
{
   __float128 a = expq(2.0Q);
	return 0;
}

Mingw gcc-4.7.x and Linux are obviously both fine.
Comment 1 Richard Biener 2014-02-27 09:00:17 UTC
Please provide at least a backtrace with debugging symbols available.
Comment 2 Hannes Domani 2014-02-27 11:25:54 UTC
This seems to be a bug in mingw-w64.
See here: http://sourceforge.net/p/mingw-w64/bugs/368/
Comment 3 Francois-Xavier Coudert 2014-10-08 14:59:34 UTC
This was apparently a bug in mingw itself, and was fixed a while back. I'm closing this report.

Please reopen it, with added info (such as backtrace), if you still see this problem with latest mingw.