Bug 57857

Summary: argument of decltype used by no return value warning
Product: gcc Reporter: David Krauss <potswa>
Component: c++Assignee: Not yet assigned to anyone <unassigned>
Status: RESOLVED FIXED    
Severity: normal CC: daniel.kruegler
Priority: P3 Keywords: rejects-valid
Version: 4.9.0   
Target Milestone: ---   
See Also: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=71187
Host: Target:
Build: Known to work: 6.1.0
Known to fail: 5.5.0 Last reconfirmed:

Description David Krauss 2013-07-09 02:42:12 UTC
The following program complains that "declval() must not be used!" in a static assertion if -Wall is passed. But declval() is only present in the unevaluated context of a decltype specifier.

The issue seems to be linked to the generation of the warning message. But the warning message will be present without the static_assert if the function has more than one exit point, such as if(0) throw; or if(0) return; (the latter using -fpermissive).


#include <utility>

template <typename U>
auto foo() -> decltype(std::declval<U>() + std::declval<U>());

template <typename T>
decltype(foo<T>()) bar(T) {
//  if ( 0 ) throw;
}

int main()
{ bar(1); }
Comment 1 David Krauss 2013-07-09 02:45:59 UTC
Narrowing down the cause, the statement { 0; } silences the error but { void(0); } does not.
Comment 2 Andrew Pinski 2021-08-04 19:27:01 UTC
GCC 6+ produces:
<source>: In instantiation of 'decltype (foo<T>()) bar(T) [with T = int; decltype (foo<T>()) = int]':
<source>:13:8:   required from here
<source>:10:1: warning: no return statement in function returning non-void [-Wreturn-type]
 }
 ^

And no calling of the static_assert .