Bug 48528

Summary: [4.6 Regression] FAIL: g++.dg/cpp0x/sfinae10.C (test for excess errors)
Product: gcc Reporter: H.J. Lu <hjl.tools>
Component: c++Assignee: Not yet assigned to anyone <unassigned>
Status: RESOLVED FIXED    
Severity: normal CC: jason, jason
Priority: P3    
Version: 4.6.1   
Target Milestone: 4.6.1   
Host: Target:
Build: Known to work:
Known to fail: Last reconfirmed:

Description H.J. Lu 2011-04-09 13:55:22 UTC
On Linux/x86, revision 172224 gave

FAIL: g++.dg/cpp0x/sfinae10.C (test for excess errors)
Excess errors:
/export/gnu/import/svn/gcc-test/src-4.6/gcc/testsuite/g++.dg/cpp0x/sfinae10.C:16:38: error: cannot allocate an object of abstract type 'A'
/export/gnu/import/svn/gcc-test/src-4.6/gcc/testsuite/g++.dg/cpp0x/sfinae10.C:13:8: note:   because the following virtual functions are pure within 'A':
/export/gnu/import/svn/gcc-test/src-4.6/gcc/testsuite/g++.dg/cpp0x/sfinae10.C:13:20: note:      virtual A::~A()

This is added by revision 172193:

http://gcc.gnu.org/ml/gcc-cvs/2011-04/msg00388.html
Comment 1 Jason Merrill 2011-04-09 19:04:14 UTC
Author: jason
Date: Sat Apr  9 19:04:11 2011
New Revision: 172230

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=172230
Log:
	PR c++/48528
	* g++.dg/cpp0x/sfinae10.C: Remove abstract class.

Modified:
    branches/gcc-4_6-branch/gcc/testsuite/ChangeLog
    branches/gcc-4_6-branch/gcc/testsuite/g++.dg/cpp0x/sfinae10.C
Comment 2 Jason Merrill 2011-04-09 19:05:26 UTC
Oops, that portion of the test depended on a patch I haven't applied to 4.6.