Bug 47484

Summary: [4.4/4.5 regression] share/python/aotcompile.py and share/python/classfile.py pollute common namespace
Product: gcc Reporter: Gerald Pfeifer <gerald>
Component: libgcjAssignee: Not yet assigned to anyone <unassigned>
Status: RESOLVED FIXED    
Severity: normal CC: aph, gbenson
Priority: P2    
Version: 4.6.0   
Target Milestone: 4.6.0   
Host: Target:
Build: Known to work: 4.6.0
Known to fail: 4.4.5, 4.5.2 Last reconfirmed: 2011-01-27 11:02:45
Bug Depends on:    
Bug Blocks: 346    

Description Gerald Pfeifer 2011-01-27 01:46:37 UTC
share/python/aotcompile.py and share/python/classfile.py pollute common
namespace; cf. Bug #346.

This has been introduced by the following patch:

2008-06-30  Joshua Sumali  <jsumali@redhat.com>
        Andrew Haley  <aph@redhat.com>

        * configure.ac (java-home): new AC_ARG_ENABLE.
        (aot-compile-rpm): Likewise.
        :
        * contrib/aot-compile.in: New file.
        * contrib/aotcompile.py.in: Likewise.
        * contrib/aot-compile-rpm.in: Likewise.
        * contrib/classfile.py: Likewise.
        * contrib/rebuild-gcj-db.in: Likewise.
Comment 1 Richard Biener 2011-01-27 11:02:45 UTC
Confirmed.  I do

rm -f $RPM_BUILD_ROOT%{_datadir}/python/aotcompile.py
rm -f $RPM_BUILD_ROOT%{_datadir}/python/classfile.py

since then in our .spec file to avoid the file conflicts (I suppose
nobody needs these files anyway).
Comment 2 gary@gcc.gnu.org 2011-02-14 14:28:07 UTC
Author: gary
Date: Mon Feb 14 14:28:00 2011
New Revision: 170131

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=170131
Log:
PR libjava/47484: Install Python modules into versioned directory

Modified:
    trunk/libjava/ChangeLog
    trunk/libjava/configure
    trunk/libjava/configure.ac
Comment 3 Richard Biener 2011-04-18 14:13:13 UTC
Fixed for 4.6.  Backports would probably break more than they fix.