Bug 41768

Summary: [regression] build failue in java component.
Product: gcc Reporter: ronis
Component: libgcjAssignee: Not yet assigned to anyone <unassigned>
Status: RESOLVED DUPLICATE    
Severity: normal CC: aj, bug-classpath, gcc-bugs, java-prs, ronis, tromey
Priority: P3    
Version: 4.4.2   
Target Milestone: ---   
Host: Target:
Build: Known to work:
Known to fail: Last reconfirmed:

Description ronis 2009-10-20 17:58:13 UTC
I configured with default CFLAGS and with:

$ ../gcc/configure --host=i686-pc-linux-gnu --prefix=/usr --with-gnu-as --enable-shared --with-gnu-ld --enable-threads=posix --with-ecj-jar=/usr/share/java/ecj.jar --enable-languages=c,c++,fortran,java,objc

The java component of the build dies with:

libtool: compile:  /home/ronis/objdir/./gcc/xgcc -shared-libgcc -B/home/ronis/objdir/./gcc -nostdinc++ -L/home/ronis/objdir/i686-pc-linux-gnu/libstdc++-v3/src -L/home/ronis/objdir/i686-pc-linux-gnu/libstdc++-v3/src/.libs -B/usr/i686-pc-linux-gnu/bin/ -B/usr/i686-pc-linux-gnu/lib/ -isystem /usr/i686-pc-linux-gnu/include -isystem /usr/i686-pc-linux-gnu/sys-include -DHAVE_CONFIG_H -I. -I../../../gcc/libjava -I./include -I./gcj -I../../../gcc/libjava -Iinclude -I../../../gcc/libjava/include -I../../../gcc/libjava/classpath/include -Iclasspath/include -I../../../gcc/libjava/classpath/native/fdlibm -I../../../gcc/libjava/../boehm-gc/include -I../boehm-gc/include -I../../../gcc/libjava/libltdl -I../../../gcc/libjava/libltdl -I../../../gcc/libjava/.././libjava/../gcc -I../../../gcc/libjava/../zlib -I../../../gcc/libjava/../libffi/include -I../libffi/include -fno-rtti -fnon-call-exceptions -fdollars-in-identifiers -Wswitch-enum -D_FILE_OFFSET_BITS=64 -ffloat-store -fomit-frame-pointer -Usun -Wextra -Wall -D_GNU_SOURCE -DPREFIX=\"/usr\" -DTOOLEXECLIBDIR=\"/usr/lib\" -DJAVA_HOME=\"/usr\" -DBOOT_CLASS_PATH=\"/usr/share/java/libgcj-4.4.2.jar\" -DJAVA_EXT_DIRS=\"/usr/share/java/ext\" -DGCJ_ENDORSED_DIRS=\"/usr/share/java/gcj-endorsed\" -DGCJ_VERSIONED_LIBDIR=\"/usr/lib/gcj-4.4.2-10\" -DPATH_SEPARATOR=\":\" -DECJ_JAR_FILE=\"/usr/share/java/ecj.jar\" -DLIBGCJ_DEFAULT_DATABASE=\"/usr/lib/gcj-4.4.2-10/classmap.db\" -DLIBGCJ_DEFAULT_DATABASE_PATH_TAIL=\"gcj-4.4.2-10/classmap.db\" -g -O2 -D_GNU_SOURCE -MT posix-threads.lo -MD -MP -MF .deps/posix-threads.Tpo -c ../../../gcc/libjava/posix-threads.cc -o posix-threads.o >/dev/null 2>&1
here=`pwd`; cd ../../../gcc/libjava/classpath/lib; \
	find gnu java javax org sun -name .svn -prune -o -name '*.class' -print | \
	gjar -cfM@ $here/libgcj-4.4.2.jar
jar: internal error:
java.lang.NullPointerException
   at gnu.classpath.tools.jar.Creator.writeCommandLineEntries(libgcj-tools.so.10)
   at gnu.classpath.tools.jar.Creator.run(libgcj-tools.so.10)
   at gnu.classpath.tools.jar.Main.run(libgcj-tools.so.10)
   at gnu.classpath.tools.jar.Main.main(libgcj-tools.so.10)
make[3]: *** [libgcj-4.4.2.jar] Error 1
make[3]: Leaving directory `/home/ronis/objdir/i686-pc-linux-gnu/libjava'

This worked on another machine, so I'm not sure that the problem isn't related to my setup here.  I'm running on a HP pavilion laptop, with slackware 12.2.

I'm also wondering if this might have something to do with an earlier bug I reported:  GCC Bugzilla Bug 41472
Comment 1 Andrew Pinski 2009-10-20 17:59:33 UTC
The gjar you have installed is broken.
Comment 2 ronis 2009-10-20 18:06:05 UTC
Shouldn't gjar be built (and used) by the bootstrap build?  It seems that it was:

 find -name gjar -ls
4108357    4 -rwxr-xr-x   1 ronis    ronis        2048 Oct 20 02:27 ./i686-pc-linux-gnu/libjava/classpath/tools/gjar

There is a system installed one from my last gcc build.

So, if this is broken, there's still a problem.  
Comment 3 Richard Biener 2009-10-21 11:22:32 UTC
gjar is broken.

*** This bug has been marked as a duplicate of 39177 ***