User account creation filtered due to spam.

Bug 23718

Summary: ffitarget.h include problem
Product: gcc Reporter: bernd.paysan
Component: libffiAssignee: Not yet assigned to anyone <unassigned>
Status: RESOLVED DUPLICATE    
Severity: minor CC: bernd.paysan, gcc-bugs, java-prs, magnus.bergman, tromey
Priority: P2    
Version: 4.0.0   
Target Milestone: ---   
Host: Target:
Build: Known to work:
Known to fail: Last reconfirmed: 2006-01-05 14:23:24

Description bernd.paysan 2005-09-03 19:55:54 UTC
Hi,    
  
On install, GCC copies ffitarget.h to    
  
<LIBDIR>/gcc/<TARGET>/<VERSION>/include/libffi/ffitarget.h    
  
However, ffi.h tries to #include <ffitarget.h>, and can't find it (no wonder).    
Correction: Either put ffitarget.h into    
<LIBDIR>/gcc/<TARGET>/<VERSION>/include, or change the line in ffi.h to    
#include <libffi/ffitarget.h>.  
  
This should be invariant of the platform; I just checked on x86_64. 4.0.1 
should be affected as well.
Comment 1 Tom Tromey 2005-09-25 21:35:30 UTC
*** Bug 16832 has been marked as a duplicate of this bug. ***
Comment 2 Andrew Pinski 2005-09-26 03:28:56 UTC
Confirmed.
Comment 3 David Daney 2007-08-10 08:17:59 UTC

*** This bug has been marked as a duplicate of 23935 ***