Bug 20925

Summary: "Possible frontend bug: array constructor not expanded"
Product: gcc Reporter: Andrew Pinski <pinskia>
Component: fortranAssignee: Not yet assigned to anyone <unassigned>
Status: RESOLVED DUPLICATE    
Severity: normal CC: gcc-bugs, gnalle
Priority: P2 Keywords: ice-on-valid-code
Version: 4.1.0   
Target Milestone: ---   
Host: Target:
Build: Known to work:
Known to fail: Last reconfirmed: 2005-04-15 12:37:42

Description Andrew Pinski 2005-04-09 22:25:34 UTC
The following code ICEs:
program sel
    implicit none
    integer,parameter              :: n=1000
    integer			   :: cste, i
    integer, dimension(n)          :: vect=(/ (-i, i=1,n) /)
    cste = vect(1)
end

t.f90: In function 'MAIN__':
t.f90:6: internal compiler error: Possible frontend bug: array constructor not expanded
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
Comment 1 Andrew Pinski 2005-04-09 22:27:27 UTC
Note this one and PR 20923, I found with the benchmark here:
<http://www.idris.fr/data/publications/F95/test_F95_english.html>
which is about f95 features.
Comment 2 Andrew Pinski 2005-04-09 22:29:18 UTC
Hmm,
              /* Problems occur when we get something like
                 integer :: a(lots) = (/(i, i=1,lots)/)  */
              /* TODO: Unexpanded array initializers.  */
              internal_error
                ("Possible frontend bug: array constructor not expanded");

Shouldn't we just create a loop at this point?
Comment 3 Andrew Pinski 2005-05-05 20:12:04 UTC
*** Bug 21394 has been marked as a duplicate of this bug. ***
Comment 4 Andrew Pinski 2005-05-14 20:58:22 UTC

*** This bug has been marked as a duplicate of 19925 ***