Bug 20822

Summary: makeinfo cannot process gnat_ugn_unw.texi
Product: gcc Reporter: Rolf Ebert <rolf.ebert.gcc>
Component: adaAssignee: Not yet assigned to anyone <unassigned>
Status: RESOLVED FIXED    
Severity: normal CC: charlet, eric.weddington, gcc-bugs, P.Schaffnit
Priority: P2 Keywords: patch
Version: 3.4.3   
Target Milestone: 4.4.0   
Host: mingw32 Target: mingw32
Build: Known to work:
Known to fail: Last reconfirmed: 2005-07-13 02:39:03
Attachments: patch to fix PR20822 in 4.0.0-RC1

Description Rolf Ebert 2005-04-08 08:03:33 UTC
when bootstrapping on Windows (mingw/msys) the documentation is not generated.  
Makeinfo stops with the complaint:

$ cat -v make.err 
doc/gnat_ugn_unw.texi:92: Unknown index `fn' and/or `cp^M' in @synindex.
./doc/gnat_ugn_unw.texi:11211: Cross reference to nonexistent node 
`Alternative^M File Naming Schemes'.

See the CR characters after cp and after Alternative.

I suppose it is a similar problem as the ones that get fixed by http://gcc.gnu.
org/ml/gcc-patches/2005-03/msg02615.html

a simple workaround for finishing bootstrap is to use make -k and simply do 
without the doc.
Comment 1 Eric Weddington 2005-04-08 11:48:54 UTC
I got this same error as Rolf did, building an AVR cross GCC with Ada on MinGW.
Could someone with more permissions be willing to set the Status as NEW?

Eric Weddington
Comment 2 Rolf Ebert 2005-04-11 12:37:06 UTC
Created attachment 8590 [details]
patch to fix PR20822 in 4.0.0-RC1
Comment 3 Laurent GUERBY 2005-04-13 06:48:14 UTC
Arnaud, may be a candidate for review?
Comment 4 charlet@adacore.com 2005-04-13 08:32:01 UTC
Subject: Re:  makeinfo cannot process gnat_ugn_unw.texi

> Arnaud, may be a candidate for review?

Sure. I'd suggest posting the patch to gcc-patches@

Arno
Comment 5 Eric Weddington 2005-04-13 15:43:20 UTC
FYI, I've tested the patch on my system here and it works for me.

Eric
Comment 6 Samuel Tardieu 2008-04-14 09:40:24 UTC
Subject: Bug 20822

Author: sam
Date: Mon Apr 14 09:39:39 2008
New Revision: 134257

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=134257
Log:
2008-04-14  Rolf Ebert  <rolf.ebert.gcc@gmx.de>

    gcc/ada/
	PR ada/20822
	* xgnatugn.adb (Put_Line): New procedure, ensuring Unix
	line endings even on non-Unix platforms.


Modified:
    trunk/gcc/ada/ChangeLog
    trunk/gcc/ada/xgnatugn.adb

Comment 7 Samuel Tardieu 2008-04-14 09:48:37 UTC
Thanks Rolf, patch applied in SVN.