Bug 18232

Summary: [4.0 Regression] ../../gcc/gcc/tree-ssa-operands.c:1624: warning: 'bi$ptr2' is used uninitialized in this function
Product: gcc Reporter: John David Anglin <danglin>
Component: tree-optimizationAssignee: Andrew Pinski <pinskia>
Status: RESOLVED FIXED    
Severity: normal CC: gcc-bugs, lucier
Priority: P2 Keywords: build
Version: 4.0.0   
Target Milestone: 4.0.0   
Host: Target: hppa-unknown-linux-gnu, powerpc-darwin
Build: Known to work:
Known to fail: Last reconfirmed: 2004-10-30 19:14:19
Bug Depends on:    
Bug Blocks: 24639    

Description John David Anglin 2004-10-30 19:11:19 UTC
stage1/xgcc -Bstage1/ -B/home/dave/opt/gnu/gcc/gcc-4.0.0/hppa-linux/bin/ -c   -g
 -O2 -DIN_GCC   -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototype
s -pedantic -Wno-long-long -Wno-variadic-macros -Wold-style-definition -Werror -
fno-common   -DHAVE_CONFIG_H    -I. -I. -I../../gcc/gcc -I../../gcc/gcc/. -I../.
./gcc/gcc/../include -I../../gcc/gcc/../libcpp/include  ../../gcc/gcc/tree-ssa-o
perands.c -o tree-ssa-operands.o
cc1: warnings being treated as errors
../../gcc/gcc/tree-ssa-operands.c: In function 'get_expr_operands':
../../gcc/gcc/tree-ssa-operands.c:1624: warning: 'bi$ptr2' is used uninitialized
 in this function
make[2]: *** [tree-ssa-operands.o] Error 1

Aside from the unitialized error, the warning is garbled.
Comment 1 Andrew Pinski 2004-10-30 19:14:19 UTC
Mine, I posted a patch for this already:
<http://gcc.gnu.org/ml/gcc-patches/2004-10/msg02688.html>.
Comment 2 dave 2004-10-30 19:33:28 UTC
Subject: Re:  ../../gcc/gcc/tree-ssa-operands.c:1

> Mine, I posted a patch for this already:
> <http://gcc.gnu.org/ml/gcc-patches/2004-10/msg02688.html>.

What about the garbled warning 'bi$ptr2'?

Dave
Comment 3 Andrew Pinski 2004-10-30 19:37:37 UTC
if you are talking about how the quotes are, then you have a LC_* set to UTF-8 so it looks like junk 
because your terminal does not support UTF-8.

If you are talking about "bi$ptr2" being werid, it really is bi.ptr2 which is PR 14329.
Comment 4 dave 2004-10-30 19:45:49 UTC
Subject: Re:  ../../gcc/gcc/tree-ssa-operands.c:1

> ------- Additional Comments From pinskia at gcc dot gnu dot org  2004-10-30
> 19:37 -------
> if you are talking about how the quotes are, then you have a LC_* set to
> UTF-8 so it looks like junk 
> because your terminal does not support UTF-8.

No.

> If you are talking about "bi$ptr2" being werid, it really is bi.ptr2 which
> is PR 14329.

So, how did . become $?  Typically, I do gcc builds in the background
with nohup with standard output and standard error directed to a file,
not a terminal.  The transformation occurs irrespective of whether
LANG=C is set in my environment or not.  I have none of the  LC_* set.

Dave
Comment 5 Andrew Pinski 2004-10-30 19:49:22 UTC
(In reply to comment #4)
> Subject: Re:  ../../gcc/gcc/tree-ssa-operands.c:1
> 
> > If you are talking about "bi$ptr2" being werid, it really is bi.ptr2 which
> > is PR 14329.
> 
> So, how did . become $?  

When we do scalar replacement assignment (aka SRA) we create new decls with a name where we is 
"oldvariable$field" instead of just "oldvariable.field", anyways in this case, the warning is not really 
right.
Comment 6 Giovanni Bajo 2004-10-31 10:28:58 UTC
*** Bug 18245 has been marked as a duplicate of this bug. ***
Comment 7 Andrew Pinski 2004-11-01 22:22:06 UTC
Note I filed PR 18268 for the SRA problem.
I will now commit my patch.
Comment 8 Andrew Pinski 2004-11-01 22:24:11 UTC
Fixed.
Comment 9 CVS Commits 2004-11-01 22:25:04 UTC
Subject: Bug 18232

CVSROOT:	/cvs/gcc
Module name:	gcc
Changes by:	pinskia@gcc.gnu.org	2004-11-01 22:24:53

Modified files:
	gcc            : ChangeLog bitmap.h 

Log message:
	2004-11-01  Andrew Pinski  <pinskia@physics.uc.edu>
	
	PR bootstrap/18232
	* bitmap.h (bmp_iter_end_p): Take a const pointer instead of a struct.
	(EXECUTE_IF_SET_IN_BITMAP): Update call to bmp_iter_end_p.
	(EXECUTE_IF_AND_COMPL_IN_BITMAP): Likewise.
	(EXECUTE_IF_AND_IN_BITMAP): Likewise.

Patches:
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/ChangeLog.diff?cvsroot=gcc&r1=2.6124&r2=2.6125
http://gcc.gnu.org/cgi-bin/cvsweb.cgi/gcc/gcc/bitmap.h.diff?cvsroot=gcc&r1=1.39&r2=1.40