Bug 16268

Summary: Bootstrap failed on libgcj : Dl_info undeclared.
Product: gcc Reporter: Ed Smith-Rowland <3dw4rd>
Component: libgcjAssignee: Not yet assigned to anyone <unassigned>
Status: RESOLVED WORKSFORME    
Severity: normal CC: gcc-bugs, java-prs
Priority: P2    
Version: 3.4.1   
Target Milestone: ---   
Host: powerpc-apple-darwin7.4.0 Target: powerpc-apple-darwin7.4.0
Build: powerpc-apple-darwin7.4.0 Known to work:
Known to fail: Last reconfirmed:

Description Ed Smith-Rowland 2004-06-29 14:39:40 UTC
Bootstrap fails on build of libgcj

/bin/sh ./libtool --tag=CXX --mode=compile /Users/ed/obj-3.4.1/gcc/xgcc
-shared-libgcc -B/Users/ed/obj-3.4.1/gcc/ -nostdinc++
-L/Users/ed/obj-3.4.1/powerpc-apple-darwin7.4.0/libstdc++-v3/src
-L/Users/ed/obj-3.4.1/powerpc-apple-darwin7.4.0/libstdc++-v3/src/.libs
-B/Users/ed/gcc-3.4.1/powerpc-apple-darwin7.4.0/bin/
-B/Users/ed/gcc-3.4.1/powerpc-apple-darwin7.4.0/lib/ -isystem
/Users/ed/gcc-3.4.1/powerpc-apple-darwin7.4.0/include -isystem
/Users/ed/gcc-3.4.1/powerpc-apple-darwin7.4.0/sys-include -DHAVE_CONFIG_H -I.
-I../../../Tarballs/gcc-3.4.1-20040625/libjava -I./include -I./gcj
-I../../../Tarballs/gcc-3.4.1-20040625/libjava -Iinclude
-I../../../Tarballs/gcc-3.4.1-20040625/libjava/include
-I/Users/ed/Tarballs/gcc-3.4.1-20040625/boehm-gc/include  -DGC_DARWIN_THREADS=1
-DTHREAD_LOCAL_ALLOC=1 -DSILENT=1 -DNO_SIGNALS=1 -DALL_INTERIOR_POINTERS=1
-DJAVA_FINALIZATION=1 -DGC_GCJ_SUPPORT=1 -DATOMIC_UNCOLLECTABLE=1  
-I../../../Tarballs/gcc-3.4.1-20040625/libjava/libltdl
-I../../../Tarballs/gcc-3.4.1-20040625/libjava/libltdl 
-I../../../Tarballs/gcc-3.4.1-20040625/libjava/.././libjava/../gcc
-I../../../Tarballs/gcc-3.4.1-20040625/libjava/../zlib
-I../../../Tarballs/gcc-3.4.1-20040625/libjava/../libffi/include
-I../libffi/include  -O2 -g -O2 -fno-rtti -fnon-call-exceptions 
-fdollars-in-identifiers -Wswitch-enum -I/usr/X11R6/include -W -Wall
-D_GNU_SOURCE -DPREFIX="\"/Users/ed/gcc-3.4.1\""
-DLIBDIR="\"/Users/ed/gcc-3.4.1/lib\""
-DBOOT_CLASS_PATH="\"/Users/ed/gcc-3.4.1/share/java/libgcj-3.4.1.jar\"" -g -O2
-MD -MT gnu/gcj/runtime/natNameFinder.lo -MF gnu/gcj/runtime/natNameFinder.pp -c
-o gnu/gcj/runtime/natNameFinder.lo
../../../Tarballs/gcc-3.4.1-20040625/libjava/gnu/gcj/runtime/natNameFinder.cc
/Users/ed/obj-3.4.1/gcc/xgcc -shared-libgcc -B/Users/ed/obj-3.4.1/gcc/
-nostdinc++ -L/Users/ed/obj-3.4.1/powerpc-apple-darwin7.4.0/libstdc++-v3/src
-L/Users/ed/obj-3.4.1/powerpc-apple-darwin7.4.0/libstdc++-v3/src/.libs
-B/Users/ed/gcc-3.4.1/powerpc-apple-darwin7.4.0/bin/
-B/Users/ed/gcc-3.4.1/powerpc-apple-darwin7.4.0/lib/ -isystem
/Users/ed/gcc-3.4.1/powerpc-apple-darwin7.4.0/include -isystem
/Users/ed/gcc-3.4.1/powerpc-apple-darwin7.4.0/sys-include -DHAVE_CONFIG_H -I.
-I../../../Tarballs/gcc-3.4.1-20040625/libjava -I./include -I./gcj
-I../../../Tarballs/gcc-3.4.1-20040625/libjava -Iinclude
-I../../../Tarballs/gcc-3.4.1-20040625/libjava/include
-I/Users/ed/Tarballs/gcc-3.4.1-20040625/boehm-gc/include -DGC_DARWIN_THREADS=1
-DTHREAD_LOCAL_ALLOC=1 -DSILENT=1 -DNO_SIGNALS=1 -DALL_INTERIOR_POINTERS=1
-DJAVA_FINALIZATION=1 -DGC_GCJ_SUPPORT=1 -DATOMIC_UNCOLLECTABLE=1
-I../../../Tarballs/gcc-3.4.1-20040625/libjava/libltdl
-I../../../Tarballs/gcc-3.4.1-20040625/libjava/libltdl
-I../../../Tarballs/gcc-3.4.1-20040625/libjava/.././libjava/../gcc
-I../../../Tarballs/gcc-3.4.1-20040625/libjava/../zlib
-I../../../Tarballs/gcc-3.4.1-20040625/libjava/../libffi/include
-I../libffi/include -O2 -g -O2 -fno-rtti -fnon-call-exceptions
-fdollars-in-identifiers -Wswitch-enum -I/usr/X11R6/include -W -Wall
-D_GNU_SOURCE -DPREFIX=\"/Users/ed/gcc-3.4.1\"
-DLIBDIR=\"/Users/ed/gcc-3.4.1/lib\"
-DBOOT_CLASS_PATH=\"/Users/ed/gcc-3.4.1/share/java/libgcj-3.4.1.jar\" -g -O2 -MD
-MT gnu/gcj/runtime/natNameFinder.lo -MF gnu/gcj/runtime/natNameFinder.pp -c
../../../Tarballs/gcc-3.4.1-20040625/libjava/gnu/gcj/runtime/natNameFinder.cc 
-fno-common -DPIC -o gnu/gcj/runtime/.libs/natNameFinder.o
../../../Tarballs/gcc-3.4.1-20040625/libjava/gnu/gcj/runtime/natNameFinder.cc:
In member function `java::lang::StackTraceElement*
gnu::gcj::runtime::NameFinder::dladdrLookup(gnu::gcj::RawData*, jint)':
../../../Tarballs/gcc-3.4.1-20040625/libjava/gnu/gcj/runtime/natNameFinder.cc:101:
error: `Dl_info' undeclared (first use this function)
../../../Tarballs/gcc-3.4.1-20040625/libjava/gnu/gcj/runtime/natNameFinder.cc:101:
error: (Each undeclared identifier is reported only once for each function it
appears in.)
../../../Tarballs/gcc-3.4.1-20040625/libjava/gnu/gcj/runtime/natNameFinder.cc:101:
error: expected `;' before "dl_info"
../../../Tarballs/gcc-3.4.1-20040625/libjava/gnu/gcj/runtime/natNameFinder.cc:103:
error: `dl_info' undeclared (first use this function)
../../../Tarballs/gcc-3.4.1-20040625/libjava/gnu/gcj/runtime/natNameFinder.cc:103:
error: `dladdr' undeclared (first use this function)
make[2]: *** [gnu/gcj/runtime/natNameFinder.lo] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-target-libjava] Error 2
MacOSX:~/obj-3.4.1 ed$
Comment 1 Andrew Pinski 2004-06-29 14:49:09 UTC
Looks like you have dlcompat installed which you do not need on Mac OS X 10.3.x (darwin 7.x) as it 
included with libSystem now.
Comment 2 Trevor Harmon 2004-08-12 18:35:58 UTC
I was having the same problem. It was caused by an improper
/usr/local/include/dlfcn.h installed by OpenOffice. Deleting this file fixes the
problem and apparently causes no other ill effects. More details are here:

http://fink.sourceforge.net/faq/comp-general.php?#dlfcn-from-oo
http://homepage.mac.com/sao1/fink/finpan2.html#top1