Bug 15936

Summary: install-sh script not found during "make install"
Product: gcc Reporter: Steffen Boerm <sbo>
Component: targetAssignee: Not yet assigned to anyone <unassigned>
Status: RESOLVED INVALID    
Severity: normal CC: gcc-bugs
Priority: P2    
Version: 3.4.0   
Target Milestone: ---   
Host: sparc-sun-solaris2.7 Target: sparc-sun-solaris2.7
Build: sparc-sun-solaris2.7 Known to work:
Known to fail: Last reconfirmed:

Description Steffen Boerm 2004-06-11 08:53:37 UTC
I have created a directory gcc-build and configured gcc-3.4.0 by

  ../gcc-3.4.0/configure --prefix=/usr/people/sbo/alpha \
     --with-gnu-ld --with-ld=/usr/people/sbo/alpha/bin/ld \
     --with-gnu-as --with-as=/usr/people/sbo/alpha/bin/as \
     --disable-nls

Since I am building under Solaris, I also told the configure script to use
/bin/ksh instead of the standard /bin/sh.

"make profiledbootstrap" works just fine (takes several days to complete), but
"make install" fails for a number of libraries (e.g., libf2c) because it wants
to use "../gcc-3.4.0/install-sh". Apparently some Makefiles do not like relative
path names at all.

As a crude bugfix, I have created symbolic links to the gcc-3.4.0 directory in
all subdirectories of the build hierarchy, but this is obviously not the most
elegant solution of all.
Comment 1 Eric Botcazou 2004-06-11 09:07:10 UTC
Configure with an absolute path, as prescribed in:
http://gcc.gnu.org/install/specific.html#*-*-solaris2*