Bug 15888

Summary: [4.0 Regression] ICE in size_binop, at fold-const.c:1661
Product: gcc Reporter: Anthony Green <green>
Component: javaAssignee: Not yet assigned to anyone <unassigned>
Status: RESOLVED WORKSFORME    
Severity: normal CC: gcc-bugs, java-prs
Priority: P2 Keywords: ice-on-valid-code
Version: 4.0.0   
Target Milestone: 4.0.0   
Host: Target:
Build: Known to work:
Known to fail: Last reconfirmed: 2004-09-28 16:43:46
Bug Depends on:    
Bug Blocks: 17574    

Description Anthony Green 2004-06-09 07:17:53 UTC
Found while building JacORB with Ant 1.6.1.  No small test case yet.

    [javac] /tmp/ccfO9RH6jx:0: internal compiler error: in size_binop, at
fold-const.c:1661
    [javac] Please submit a full bug report,
    [javac] with preprocessed source if appropriate.
    [javac] See <URL:http://gcc.gnu.org/bugs.html> for instructions.
 


bug appears when building JacORB_2_2/src/org/jacorb/config/Configuration.java to
bytecode.

Reproduce by building & installing rhug's Ant, as well as gnu-crypto and jessie,
and then running "ant" on JacORB 2.2.

(gdb) where
#0  fancy_abort (file=0x8497b68
"/home/green/sources/jhbuild-src/gcc/gcc/fold-const.c", line=-152194352,
    function=0x8497b68 "/home/green/sources/jhbuild-src/gcc/gcc/fold-const.c")
    at /home/green/sources/jhbuild-src/gcc/gcc/diagnostic.c:590
#1  0x08235f35 in size_binop (code=PLUS_EXPR, arg0=0x84978c0, arg1=0xf6ed1e88)
    at /home/green/sources/jhbuild-src/gcc/gcc/fold-const.c:1661
#2  0x08093bef in set_method_index (decl=0xf67b95e4, method_index=0x8497b68)
    at /home/green/sources/jhbuild-src/gcc/gcc/java/class.c:1444
#3  0x08095ee1 in layout_class_method (this_class=0xf67b73a0,
super_class=0xf67b71d0, method_decl=0xf67b95e4,
    dtable_count=0xf5b91618) at
/home/green/sources/jhbuild-src/gcc/gcc/java/class.c:2216
#4  0x080964ba in layout_class_methods (this_class=0xf67b73a0) at
/home/green/sources/jhbuild-src/gcc/gcc/java/class.c:2147
#5  0x0805e124 in java_layout_seen_class_methods () at parse.y:7587
#6  0x0805e433 in java_layout_classes () at parse.y:7652
#7  0x0807b378 in java_expand_classes () at parse.y:9001
#8  0x080c571d in java_parse_file (set_yydebug=0) at
/home/green/sources/jhbuild-src/gcc/gcc/java/jcf-parse.c:1111
#9  0x083a7d6b in toplev_main (argc=139033448, argv=0xfeebc9a4) at
/home/green/sources/jhbuild-src/gcc/gcc/toplev.c:1654
#10 0x00125ad4 in __libc_start_main () from /lib/tls/libc.so.6
#11 0x08049c21 in _start ()
Comment 1 Andrew Pinski 2004-09-22 03:58:18 UTC
I think this is a regression.
Comment 2 Tom Tromey 2004-09-23 00:52:38 UTC
Anthony, do you have your build tree around somewhere?
Could you put a tar file of it somewhere I can grab it?
That would make this easier... thanks.
If not, let me know soon if you could.
Comment 3 Anthony Green 2004-09-23 14:16:08 UTC
Subject: Re:  [4.0 Regression] ICE in size_binop, at
	fold-const.c:1661

On Wed, 2004-09-22 at 17:52, tromey at gcc dot gnu dot org wrote:
> ------- Additional Comments From tromey at gcc dot gnu dot org  2004-09-23 00:52 -------
> Anthony, do you have your build tree around somewhere?
> Could you put a tar file of it somewhere I can grab it?
> That would make this easier... thanks.
> If not, let me know soon if you could.

No, I don't have this handy.  I'll try to reproduce today for you.

Thanks,

AG


Comment 4 Andrew Haley 2004-09-28 14:07:14 UTC
Try it with today's patch.
Comment 5 Tom Tromey 2004-09-28 16:21:28 UTC
FWIW I can reproduce this compiling jakarta-ant
with current cvs trunk gcj, with my PR 15710
patch applied (to get past earlier compile errors).
I only updated gcc/java, I'll try again with a full
update, and I'll submit my patch.
Comment 6 Andrew Pinski 2004-09-28 16:43:45 UTC
Back to new for now.
Comment 7 Andrew Haley 2004-09-30 08:06:36 UTC
I can't duplicate this problem with the current CVS gcj.

x86_64-unknown-linux-gnu built jakarta-ant from rhug once a few rhug configury
problems caused by x86_64 were fixed.