Bug 13280

Summary: [gfortan] ICE for IO of derived type with character components
Product: gcc Reporter: Steven Bosscher <steven>
Component: fortranAssignee: Not yet assigned to anyone <unassigned>
Status: RESOLVED DUPLICATE    
Severity: normal CC: gcc-bugs
Priority: P2 Keywords: ice-on-valid-code
Version: tree-ssa   
Target Milestone: tree-ssa   
Host: Target:
Build: Known to work:
Known to fail: Last reconfirmed: 2003-12-16 23:33:56
Bug Depends on:    
Bug Blocks: 13569    

Description Steven Bosscher 2003-12-03 10:32:32 UTC
subroutine bug 
  implicit none 
 
  type :: type1 
     character, dimension(2) :: field1 
     integer :: field2 
  end type type1 
 
  type (type1) :: foo 
 
  print *, foo%field2 
end subroutine bug 
 
t.f90: In function `bug': 
 
t.f90:1: internal compiler error: in gfc_get_dtype_cst, at fortran/
trans-types.c:584 
Please submit a full bug report, 
with preprocessed source if appropriate. 
See <URL:http://gcc.gnu.org/bugs.html> for instructions. 
 
More fun with derived types and character arrays...
Comment 1 Andrew Pinski 2003-12-05 23:17:35 UTC
Confirmed.
Comment 2 Andrew Pinski 2004-01-05 19:00:21 UTC
This is a dup of bug 13253.

*** This bug has been marked as a duplicate of 13253 ***