This is the mail archive of the libstdc++@gcc.gnu.org mailing list for the libstdc++ project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: libstdcxx_so_7 branch (was Re: [Patch/RFC] libstdc++/19495)


Paolo Carlini wrote:
Jonathan Wakely wrote:

Hi all,

Apologies if I missed it - is the so_7 branch targetted at a particular
release yet, or will it just be "the next one that's not ABI-compatible
with 3.4" ?


AFAIK, at the moment, simply the latter.

The SC will have to decide when it will be appropriate to make a release that's not ABI-compatible with 3.4. I don't have a preconceived notion of the right answer here, but the effect on the overall GCC project will be large. It may make sense to do the V3 change at the same time as making any necessary incompatible updates to the G++ or libgcc ABIs, for example, should that be necessary.


Do the V3 people currently have thoughts about when they would like to switch?

--
Mark Mitchell
CodeSourcery, LLC
mark@codesourcery.com
(916) 791-8304


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]