This is the mail archive of the libstdc++@gcc.gnu.org mailing list for the libstdc++ project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: Fresh $prefix required to avoid any upgrade trouble?


On Thu, Jun 07, 2001 at 02:03:51AM -0500, Loren James Rittle wrote:
> Do we need to inform people installing gcc 3.0 that they should use a
> fresh $prefix to avoid any possible trouble?
> 
> For background, we current say this in gcc/doc/install.texi:
> 
> > Please note that GCC does not support @samp{make uninstall} and probably
> > won't do so in the near future as this would open a can of worms. Instead, 
> > we suggest that you install GCC into a directory of its own and simply
> > remove that directory when you do not need that specific version of GCC
> > any longer.

libstdc++ is part of the compiler, so the same instructions and caveats
apply.  I believe some form of that paragraph appears on the main gcc web
page as well, somewhere in the installation instructions.

-- 
pedwards at disaster dot jaj dot com  |  pme at sources dot redhat dot com
devphil at several other less interesting addresses in various dot domains
The gods do not protect fools.  Fools are protected by more capable fools.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]