This is the mail archive of the libstdc++@sources.redhat.com mailing list for the libstdc++ project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

I'm having problems compiling on FreeBSD 4.0


Hi,

I'm trying to compile libstdc++-v3 from CVS on a FreeBSD 4-stable machine.
But, I'm running into problems during compilation.

At first I got a bunch of 'data definition has 
no type or storage class' warnings in gcc/libstdc++v3/libio/_G_config.h and libio.h .

I believe this has to do with the fact that __off_t and __off64_t in <sys/types.h> are actually both off_t on my machine. For the error in libio.h, again, on my machine __ssize_t is actually ssize_t. So, I thought no problem, I'll just modify _G_config.h to define __off_t and __off64_t as off_t, and __ssize_t as ssize_t. That got rid of some of the errors, but there's some more:

rm -f .libs/filedoalloc.lo
/usr/local/pub/development/libstdc++/obj/gcc/xgcc -B/usr/local/pub/development/l
ibstdc++/obj/gcc/ -B/usr/i386-unknown-freebsd4.0/bin/ -DHAVE_CONFIG_H -I. -I../.
./../../gcc/libstdc++-v3/libio -I.. -D_GNU_SOURCE -nostdinc++ -I../../../../gcc/
libstdc++-v3 -I../libio -I../../../../gcc/libstdc++-v3/libio -I../../../../gcc/l
ibstdc++-v3/config/cpu/i386 -I../../../../gcc/libstdc++-v3/config/bsd -I/usr/inc
lude -g -O2 -c  -fPIC -DPIC ../../../../gcc/libstdc++-v3/libio/filedoalloc.c -o 
.libs/filedoalloc.lo
In file included from ../../../../gcc/libstdc++-v3/libio/iolibio.h:2,
                 from ../../../../gcc/libstdc++-v3/libio/libioP.h:37,
                 from ../../../../gcc/libstdc++-v3/libio/filedoalloc.c:49:
../../../../gcc/libstdc++-v3/libio/libio.h:394: parse error before `__THROW'
../../../../gcc/libstdc++-v3/libio/libio.h:394: warning: data definition has no 
type or storage class


This error, apparently refers to the following line in libio.h:
extern int __underflow (_IO_FILE *) __THROW;

(There are several more declarations below this that generate the same error: __uflow, __overflow, etc. They all use _IO_FILE)
I believe the problem is with the _IO_FILE type, but I haven't really been able to figure it out. 

Has anyone tried compiling libstdc++-v3 on a FreeBSD 4.0 machine? Am I doing something wrong? Any help would be greatly appreciated.

By the way, I'm using gcc 95.2 and yesterday's CVS source from anoncvs.cygnus.com.


Mikem.



Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]