This is the mail archive of the libstdc++@sourceware.cygnus.com mailing list for the libstdc++ project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Reformatted post: Undefined reference to _IO_file_open


Hello once again,

When I read the message I posted yesterday on this list I realized that my
web based email client didn't format it correctly and it's therefore hard to
read. So I try to repost it with better formatting today, sorry for the in-
convenience. I hope it's better to read now...

By the way, the following problem also applies to the libstdc++ version that
originally comes with gcc 2.95.2, not only libstdc++-v3.

--- Start of re-post:

Sorry, I'm new to this list and the libstdc++ thing in general so this
question might sound silly to you but I don't know what to do anymore.
Here's the problem:

My current libstdc++ (2.9) that is installed on my Linux system (SuSE 6.0
based x86 Linux with glibc 2.0.7 and kernel 2.2.14, binutils 2.9.5.0.15)
seems to have problems with all that is related to iostreams (software
that uses it crashes with a segfault or doesn't compile at all). Therefore,
I downloaded a new GCC (2.95.2) and the latest official libstdc++-v3
snapshot 2.90.8.

Then I compiled GCC 2.95.2 and used libstdc++-v3 as a drop-in replacement
for the one that comes with GCC. After compiling ("make bootstrap"), I ran
"made check" and everything worked fine, no error at all. GCC 2.95.2
works perfectly, too.

However, after installing the new libstdc++.so as the standard library, a
configure for most software fails when it tries to link a C++ test routine.
The error is "undefined reference to _IO_file_open." Can you tell me what's
wrong here?! I've found the IO_file_open routine in the libio path and I
simply "removed" it just to see what happens (there's a #ifdef definition
there, I used the #else path instead). After compiling the library again,
the error message above disappeared but it now has an "undefined reference
to _IO_getfile_info" instead...

What is this? Can you help me?! Oh, my configure-flags for GCC were:
--prefix=/usr --enable-shared --enable-threads
--enable-version-specific-runtime-libs

Thanks in advance for all your ideas and help.

Regards, Stefan.

_______________________________________________________________________
1.000.000 DM gewinnen - kostenlos tippen - http://millionenklick.web.de
IhrName@web.de, 8MB Speicher, Verschluesselung - http://freemail.web.de


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]