This is the mail archive of the mailing list for the Java project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: Redhat GCC 2.96 won't work? java/lang/ bad value constant type 0, index 0

Hash: SHA1

Tom Tromey <> writes:

> >>>>> "Kevin" == Kevin A Burton <> writes:
> Kevin> burton@universe:/usr/home/burton/gcc
> Kevin> gcj 
> Kevin> java/lang/ bad value constant type 0, index 0
> I've only seen this when I've tried to compile a .class file that was
> built by the 1.2 JDK.
> Do you have your CLASSPATH set?  If so, unset it.

AH!!! That makes perfect sense! :).  It works now.  Time to have fun!! :)

> If not, try sending the output of `gcj -v'.
> Kevin> What is up with this?  Could it be the stupid compiler that
> Kevin> comes with RedHat 7?
> I seriously doubt it.  For one thing, I dispute your characterization
> of that compiler.  It is probably the best released gcj so far.

ah... not totally my characterization.  A lot of people flame it and one could
assume they have at least logical reasons.  This is why I doubted it :)..


- -- 
Kevin A. Burton (,, )
        Cell: 408-910-6145 URL: ICQ: 73488596 

Fist in the air in the land of hypocrisy!
Version: GnuPG v1.0.4 (GNU/Linux)
Comment: Get my public key at:


smuggle ammunition strategic quiche radar cracking Legion of Doom Kennedy
explosion kibo Waco, Texas PLO jihad [Hello to all my fans in domestic
surveillance] Uzi

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]