This is the mail archive of the java-discuss@sources.redhat.com mailing list for the Java project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: More bugs with inner classes (was: Freenet compilation errors.)


On Thu, 18 Jan 2001, Mark J. Roberts wrote:

> On Wed, 17 Jan 2001, Alexandre Petit-Bianco wrote:
> 
> > Mark J. Roberts writes:
> > 
> > > The source is included. My bad.
> > 
> > I checked the current version of freenet/Freenet out, I replaced
> > transport/tcpConnection.java by what you gave me and I can't reproduce
> > the error. I'm running a fairly up to date front-end, which somes
> > patches. Is what you gave me the exact command line? Where is it
> > running from (what's its wd.)
> > 
> > ./A
> 
> Amazing. A few minutes ago, I was trying to find the problem by process of
> elimination, commenting out code in both Connection.java and
> tcpConnection.java. It failed, it failed... and then it worked! So I
> uncommented the code one method at a time.
> 
> The problem DIDN'T COME BACK! I zapped my whole CVS tree and tried
> again. It worked!
> 
> This is just too strange. There were no stray .class files lying around
> before, so that's not the reason. Wow.

Okay, this may be less strange than I previously thought. It seems to
occur when I use my new Makefile.gcj, but not when I build the file
straight, with no other class files lying around.

However, if I build tcpConnection.java first, the Makefile works file, and
the build is successful.

I've committed Makefile.gcj, it's in Freenet/scripts. tcpConnection will
fail to build, unless you first (with a clean tree, no .class files) build
it seperately. If I delete Freeenet/Connection.class, and then try to
build it, it will work. Whew.

So the problem is with parsing the .class file for Connection.java. I'll
try to make a test case right now.


-- 
Mark Roberts
mjr@statesmean.com


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]