This is the mail archive of the
mailing list for the GCC project.
Re: can we rename vec<>.safe_push() to vec<>.push()?
- From: Richard Biener <richard dot guenther at gmail dot com>
- To: Aldy Hernandez <aldyh at redhat dot com>
- Cc: GCC Mailing List <gcc at gcc dot gnu dot org>
- Date: Thu, 31 Aug 2017 13:38:45 +0200
- Subject: Re: can we rename vec<>.safe_push() to vec<>.push()?
- Authentication-results: sourceware.org; auth=none
- References: <CAGm3qMUfS4x+Urp5qc0JVMqpFEiRxk-WJWCUzXOa0t1a8QpW0g@mail.gmail.com>
On Thu, Aug 31, 2017 at 1:31 PM, Aldy Hernandez <email@example.com> wrote:
> I understand the need for .quick_push(), when we know the size of the
> allocated elements before hand, but do we really need to call the
> common variant safe_push? Can't we just call it push()?
> Or is there some magic C++ rule/idiom that prohibits us from doing this?
> I volunteer to provide a patch if y'all agree.
I think having quick_push and safe_push makes you think which one to use
while push would be the obvious lazy one. Aka nobody thinks of pre-allocating
stuff and using quick_push anymore.
Just my 2 cents...