This is the mail archive of the
mailing list for the GCC project.
can we rename vec<>.safe_push() to vec<>.push()?
- From: Aldy Hernandez <aldyh at redhat dot com>
- To: GCC Mailing List <gcc at gcc dot gnu dot org>
- Date: Thu, 31 Aug 2017 07:31:02 -0400
- Subject: can we rename vec<>.safe_push() to vec<>.push()?
- Authentication-results: sourceware.org; auth=none
I understand the need for .quick_push(), when we know the size of the
allocated elements before hand, but do we really need to call the
common variant safe_push? Can't we just call it push()?
Or is there some magic C++ rule/idiom that prohibits us from doing this?
I volunteer to provide a patch if y'all agree.