This is the mail archive of the gcc@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: [Non-DoD Source] Support Library Requirements for GCC 7.1


Joel,

Normally I try building the latest gcc snapshots using the latest versions of 
prerequisite codes.  Some codes are required to build GCC itself while others 
are needed for the "make check" phase.  Below is what I use for the whole 
build and test process:

#
#  ActiveTcl-8.6.6.8606-x86_64-linux-glibc-2.5-401948.tar.gz
# 
http://www.activestate.com/activetcl/downloads
#  autoconf-2.69.tar.gz                  ftp://ftp.gnu.org/gnu/autoconf/
#  autogen-5.18.12.tar.gz 
ftp://ftp.gnu.org/gnu/autogen/rel5.18.12/
#  binutils-2.28.tar.gz                  ftp://ftp.gnu.org/gnu/binutils/
#  bison-3.0.4.tar.gz                    ftp://ftp.gnu.org/gnu/bison/
#  dejagnu-1.6.tar.gz                    ftp://ftp.gnu.org/gnu/dejagnu/
#  expect5.45.tar.gz                     http://expect.sourceforge.net/#unix
#  flex-2.6.0.tar.gz 
https://sourceforge.net/projects/flex/files/
#  gawk-4.1.4.tar.gz                     ftp://ftp.gnu.org/gnu/gawk/
#  gc-7.6.0.tar.gz                       http://www.hboehm.info/gc/gc_source/
#  gcc-${ver}.tar.bz2 
http://mirrors.concertpass.com/gcc/snapshots/${ver}/
#                                     or 
http://mirrors.concertpass.com/gcc/releases/gcc-${ver}/
#  gdb-7.12.1.tar.gz                     ftp://ftp.gnu.org/gnu/gdb/
#  gettext-0.19.8.1.tar.gz               ftp://ftp.gnu.org/gnu/gettext/
#  gmp-6.1.2.tar.bz2                     ftp://ftp.gnu.org/gnu/gmp/
#  guile-2.0.14.tar.gz                   ftp://ftp.gnu.org/gnu/guile/
#  isl-0.18.tar.gz                       http://isl.gforge.inria.fr/
#  libatomic_ops-7.4.4.tar.gz 
https://github.com/ivmai/libatomic_ops/wiki/Download
#  libffi-3.2.1.tar.gz                   https://sourceware.org/libffi/
#  libtool-2.4.6.tar.gz                  ftp://ftp.gnu.org/gnu/libtool/
#  libunistring-0.9.7.tar.gz             ftp://ftp.gnu.org/gnu/libunistring/
#  m4-1.4.18.tar.gz                      ftp://ftp.gnu.org/gnu/m4/
#  mpc-1.0.3.tar.gz                      ftp://ftp.gnu.org/gnu/mpc/
#  mpfr-3.1.5.tar.gz                     ftp://ftp.gnu.org/gnu/mpfr/
#  perl-5.24.1.tar.gz                    https://www.perl.org/get.html
#  readline-7.0.tar.gz                   ftp://ftp.gnu.org/gnu/readline/
#  texinfo-6.3.tar.gz                    ftp://ftp.gnu.org/gnu/texinfo/
#

The exception I find to using the latest codes is guile.  With guile, the 
latest version I can use is 2.0.14. There are more recent versions of guile 
(2.2.0, 2.2.1, 2.2.2), but they seem to be incompatible with the GCC testing 
phase.  Unfortunately, clicking on the "documentation" link on the 7.1 
announcement page https://gcc.gnu.org/gcc-7/ gives me

Forbidden

You don't have permission to access /onlinedocs/7.1.0/ on this server.
Apache Server at gcc.gnu.org Port 443

Tom Oppe

-----Original Message-----
From: gcc-owner@gcc.gnu.org [mailto:gcc-owner@gcc.gnu.org] On Behalf Of Joel 
Sherrill
Sent: Tuesday, May 02, 2017 6:18 PM
To: GCC Mailing List <gcc@gcc.gnu.org>
Subject: [Non-DoD Source] Support Library Requirements for GCC 7.1

Hi

I am trying to update the gcc version for rtems to 7.1 and running into 
trouble finding the correct versions of mpc, mpfr, and gmp. We build those as 
part of building gcc so we have configuration control over the set.

With gcc 6.3.0, we have this in our build recipe:

%define mpfr_version   2.4.2
%define mpc_version    0.8.1
%define gmp_version    4.3.2

I tried that with gcc 7.1.0 but the build failed complaining mpfr was too old. 
I upgraded mpfr and them got a compiler error which appeared to be GMP related 
so I bumped GMP. The same error remained:

../../../gcc-7.1.0/mpc/src/acos.c: In function 'mpc_acos':
../../../gcc-7.1.0/mpc/src/acos.c:192:19: error: 'GMP_RNDA' undeclared (first 
use in this function)
        : rnd_im == GMP_RNDA ? GMP_RNDZ

I bumped MPC to 1.0.3 which worked. Now we are using this in the build recipe.

%define mpfr_version   3.1.5
%define mpc_version    1.0.3
%define gmp_version    6.1.2

The gcc-7.1.0/INSTALL/prerequisites.html seem to be out of date. I am sure the 
minimum is lower than what I ended up using.

What are the correct minimums for gcc 7.1?

Thanks.

-joel



Attachment: smime.p7s
Description: S/MIME cryptographic signature


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]