This is the mail archive of the gcc@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Changing base compiler requirement for bootstrapping GNAT




On 1/19/2017 6:33 AM, Jakub Jelinek wrote:
On Thu, Jan 19, 2017 at 01:26:32PM +0100, Andreas Schwab wrote:
On Jan 19 2017, Tristan Gingold <gingold@adacore.com> wrote:

Is it ok to require gcc 4.9 (3 years old) or later to build GNAT ?

The newest Ada compiler available for SLE11 is 4.8.

Various people still use 4.4 or even 4.1 as bootstrap compilers.
While 3 years old requirement is way better than the Rust nonsense (only
support bootstrap with 6 weeks older Rust and not older), it is still not
good enough for GCC IMHO.

I still see a lot of people using CentOS/RHEL 6 which has
gcc 4.4.7. This is particularly true of large organizations.

What does CentOS/RHEL 7 have for gcc?

What would be the procedure to get a recent GNAT on these
distributions?  For RTEMS, we use very recent (6.3.0) gcc
for our cross tools but usually don't have to worry about
updating the native compiler. CentOS 6 is not a problem
to build up to date cross tools on currently.


	Jakub


--joel


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]