This is the mail archive of the gcc@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Bootstrap failure on aarch64-linux-gnu with trunk


On 01/13/2017 05:57 PM, Andrew Pinski wrote:
On Fri, Jan 13, 2017 at 3:56 PM, Jeff Law <law@redhat.com> wrote:
On 01/13/2017 04:54 PM, Andrew Pinski wrote:

Between revision 244386 and 244448, aarch64-linux-gnu started to
miscompare bootstrap.

These are the options I used:
--prefix=`pwd`/../tools \
--enable-languages=c,c++,fortran,go \
                 --with-cpu=thunderx \
                 --disable-werror  --with-sysroot=/ --enable-plugins \
                 --enable-gnu-indirect-function \
                 --with-pkgversion="Cavium Inc. (Build ${BUILD_NUMBER})"

On another system I did bootstrap at revision 244392 just fine but
without the --with-cpu option.

I'm pretty sure its my DSE changes. I'm seeing similar failures on ppc64le
and am about to revert once a bit more testing is complete.

If you need it to test the patch to fix this on aarch64-linux-gnu just
let me know and I would be gladly test it.  Bootstrap and test takes
around an hour or two hours depending on which machine I use.
No worries. I've got a reasonable ppc box reserved for testing purposes. I'm confident I've got the bootstrap comparison error nailed.

Jeff


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]