This is the mail archive of the
mailing list for the GCC project.
Would like to make one version of is_too_expensive in gcse.c and cprop.c
- From: Bradley Lucier <lucier at math dot purdue dot edu>
- To: gcc at gcc dot gnu dot org
- Cc: Bradley Lucier <lucier at math dot purdue dot edu>
- Date: Tue, 10 Nov 2015 21:46:27 -0500
- Subject: Would like to make one version of is_too_expensive in gcse.c and cprop.c
- Authentication-results: sourceware.org; auth=none
The routines declared as
is_too_expensive (const char *pass)
in both cprop.c and gcse.c are identical except for two comment lines.
I'd like to modify is_too_expensive, which implied to me that there
should be only one copy of the routine.
Would it be reasonable to add an extern declaration of is_too_expensive
(with perhaps a more descriptive name) in gcse.h, remove the static
declaration from gcse.c, include gcse.h in cprop.c?
(I realize this is a very simple question for regular C programmers, but
I'm not a regular C programmer, sorry).