This is the mail archive of the gcc@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: libgomp: "GNU OpenMP Runtime Library" (was: [PATCH 1/5] OpenACC 2.0 support for libgomp - OpenACC runtime, NVidia PTX/CUDA plugin (repost))


On Wed, 2014-11-12 at 12:33 +0100, Jakub Jelinek wrote:
> On Wed, Nov 12, 2014 at 12:18:13PM +0100, Thomas Schwinge wrote:
> > On Wed, 12 Nov 2014 11:06:26 +0100, Jakub Jelinek <jakub@redhat.com> wrote:
> > > On Tue, Nov 11, 2014 at 01:53:23PM +0000, Julian Brown wrote:
> > > > --- a/libgomp/configure.ac
> > > > +++ b/libgomp/configure.ac
> > > > @@ -2,6 +2,8 @@
> > > >  # aclocal -I ../config && autoconf && autoheader && automake
> > > >  
> > > >  AC_PREREQ(2.64)
> > > > +#TODO: Update for OpenACC?  But then also have to update copyright notices in
> > > > +#all source files...
> > | >  AC_INIT([GNU OpenMP Runtime Library], 1.0,,[libgomp])
> > > 
> > > Please drop this.
> > 
> > (I agree to drop the TODO marker, obviously.)  Note that I'm not trying
> > to drive this into a "bikeshedding" discussion, and neither is my
> > intention to discredit the lots of pioneering OpenMP work in GCC (which
> > we're largely basing our OpenACC work on -- thanks!).
> > 
> > The underlying question here is, with offloading generally as well as the
> > OpenACC Runtime Library also to be living in libgomp, calling it "GNU
> > OpenMP Runtime Library" is no longer accurate.  (Also, I'm not proposing
> > to change the libgomp library name -- that would probably be too much of
> > a hassle?)  Do we want a new "verbose" name for libgomp, "GNU Offloading,
> > OpenACC, and OpenMP Runtime Library" (sorting alphabetically), or
> > something else, or no change.  I'm afraid that not changing it will be
> > confusing to users who are looking for the GCC implementation of the
> > OpenACC Runtime Library, for example?
> 
> Yeah, it is something I wanted to mention in the review of the documentation
> patch, calling it just GNU OpenMP Runtime Library is not right after
> it handles OpenACC too, but GNU Offloading, OpenACC and OpenMP Runtime
> Library sounds bad to me too, because offloading (both OpenMP offloading and
> OpenACC offloading) is actually only a small part of what the library is
> about, I still view the library primarily as being a runtime for
> OpenMP parallelization, tasking etc.; that's how it started and even OpenMP
> offloading is just a matter of the last year (and until today in upstream
> not even any actual offloading), for OpenACC it is solely about
> offloading and directives in the offloaded code, right?
> 
> So, don't want to bikeshed, but I'd call it
> GNU OpenMP and OpenACC Runtime Library simply from the things what it does
> and how it evolved, I know it isn't alphabetically sorted that way, but
> it will the library has more than 9 years of history now and tons of users
> already.

Apologies for bikeshedding, and I normally dislike "cute" names, but
renaming it to

   "GNU Offloading and Multi Processing library"

would allow a backronym of "libgomp", thus preserving the existing
filenames/SONAME etc.

Dave


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]