This is the mail archive of the gcc@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: gcc 4.9.0 do not build on OSX


On Sat, May 3, 2014 at 5:48 PM, Chris Johns <chrisj@rtems.org> wrote:
> On 3/05/2014 10:57 pm, Franzi Edo. wrote:
>>
>> Hi,
>> I am trying to build a gcc-4.9.0 ARM cross compiler on OSX Mavericks
>> unsuccessfully.
>> My toolchain works fine with the previous version 4.8.2 but on the 4.9.0 I
>> have this error during the gcc building pass 1.
>>
>> /opt/uKOS/Packages/gcc-4.9.0/gcc/config/arm/neon.md:3486:10917: fatal
>> error:
>>       bracket nesting level exceeded maximum of 256
>> /opt/uKOS/Packages/gcc-4.9.0/gcc/config/arm/neon.md:3486:10917: note: use
>>       -fbracket-depth=N to increase maximum nesting level
>> 32 warnings and 1 error generated.
>> make[1]: *** [insn-attrtab.o] Error 1
>> make: *** [all-gcc] Error 2
>> Error building gcc pass 1

There is some large conditionals inside insn-attrtab.c but I don't see
any which have more than 30 depth of parenthesis.  The max level of {}
is 4 in that file too.
So this sounds like a bug in clang.  Please report it to them.

Thanks,
Andrew Pinski

>>
>> So, I tried to increase the number of nesting level as indicated
>> (-fbracket-depth=1024) but I get the same error.
>
>
> This failure can also be seen on FreeBSD 10 when building with the default c
> and c++ compilers. Adding the option to the build cflags does fix it on
> FreeBSD. I have not tried OSX yet but will at some point.
>
> I am not sure if this is something the gcc build system should manage or the
> limit is to low in clang and the issue raised there. It is an interesting
> limit to have.
>
>
>> I use these packages:
>>
>> GMP_VER=6.0.0
>> MPFR_VER=3.1.2
>> MPC_VER=1.0.2
>> BIN_VER=2.24
>> GCC_VER=4.9.0
>> NLB_VER=2.1.0
>> GDB_VER=7.7
>>
>> The configure for the pass 1 is:
>>
>> export GCC1_CONFIG=" \
>>         --enable-interwork \
>>         --enable-languages=c,c++ \
>>         --with-newlib \
>>
>> --with-headers=${PATH_TOOLS_GCC}/Packages/newlib-${NLB_VER}/newlib/libc/include
>> \
>>         --with-mpfr=${PATH_TOOLS_GCC}/cross/mpfr-${MPFR_VER} \
>>         --with-gmp=${PATH_TOOLS_GCC}/cross/gmp-${GMP_VER} \
>>         --with-mpc=${PATH_TOOLS_GCC}/cross/mpc-${MPC_VER}"
>>
>> Any idea?
>
>
> Add CFLAGS="-O2 -fbracket-depth=1024" to the command line before configure.
>
> Chris
>
>> Regards,
>>   Edo
>>
>


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]