This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: gcc 4.9.0 do not build on OSX

On 3/05/2014 10:57 pm, Franzi Edo. wrote:
I am trying to build a gcc-4.9.0 ARM cross compiler on OSX Mavericks unsuccessfully.
My toolchain works fine with the previous version 4.8.2 but on the 4.9.0 I have this error during the gcc building pass 1.

/opt/uKOS/Packages/gcc-4.9.0/gcc/config/arm/ fatal error:
      bracket nesting level exceeded maximum of 256
/opt/uKOS/Packages/gcc-4.9.0/gcc/config/arm/ note: use
      -fbracket-depth=N to increase maximum nesting level
32 warnings and 1 error generated.
make[1]: *** [insn-attrtab.o] Error 1
make: *** [all-gcc] Error 2
Error building gcc pass 1

So, I tried to increase the number of nesting level as indicated (-fbracket-depth=1024) but I get the same error.

This failure can also be seen on FreeBSD 10 when building with the default c and c++ compilers. Adding the option to the build cflags does fix it on FreeBSD. I have not tried OSX yet but will at some point.

I am not sure if this is something the gcc build system should manage or the limit is to low in clang and the issue raised there. It is an interesting limit to have.

I use these packages:


The configure for the pass 1 is:

export GCC1_CONFIG=" \
	--enable-interwork \
	--enable-languages=c,c++ \
	--with-newlib \
	--with-headers=${PATH_TOOLS_GCC}/Packages/newlib-${NLB_VER}/newlib/libc/include \
	--with-mpfr=${PATH_TOOLS_GCC}/cross/mpfr-${MPFR_VER} \
	--with-gmp=${PATH_TOOLS_GCC}/cross/gmp-${GMP_VER} \

Any idea?

Add CFLAGS="-O2 -fbracket-depth=1024" to the command line before configure.



Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]