This is the mail archive of the gcc@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Rename unwind.h to unwind-gcc.h


On Wed, Apr 16, 2014 at 12:01 AM, John Marino <gnugcc@marino.st> wrote:
> On 4/16/2014 03:22, Ian Lance Taylor wrote:
>> On Tue, Apr 15, 2014 at 4:45 AM, Douglas B Rupp <rupp@adacore.com> wrote:
>>> On 04/14/2014 02:01 PM, Ian Lance Taylor wrote:
>>>
>>> No I considered that but I think that number will be very small. Will you
>>> concede, in hindsight, that it would be better had the name been chosen to
>>> be more unique?
>>
>> No, I won't concede that.  The unwind.h file provides the interface
>> for the C++ exception handling interface
>> (http://mentorembedded.github.io/cxx-abi/abi-eh.html).  That interface
>> is implemented by several different compilers, not just GCC.
>
> The header can provide the exact same interface with a different, better
> file name.
>
> He's basically asking, "If you had it to do all over again, would you
> still call it unwind.h or would you call it something different?"
>
> It's just an academic discussion because answering yes or no changes
> nothing, but I think the majority of the people would give it a
> different file name if they could do it all over again.  It's not a big
> concession.

I agree that it doesn't matter at this date, but I would still vote to
call it unwind.h.  It's a good descriptive name for the interface
described by the file.  I certainly wouldn't call it unwind-gcc.h;
it's intentionally not GCC-specific.

Ian


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]