This is the mail archive of the
mailing list for the GCC project.
Re: Normalizing the bitmap APIs.
On 2012-10-11 13:26 , Lawrence Crowl wrote:
My only other concern was that the mapping between those function
names and the tasks to be done sometimes seemed less than obvious.
So, I proposed the name change. However, I think the current names
are workable, assuming an acceptable solution to the above problem.
I would say, add both variants and make the empty ones drop the return
value. So, for instance, bitmap_ior returns a value, so make
bitmap_ior_cg drop it.