This is the mail archive of the gcc@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Regenerating configure scripts


Hello Michael,

* Michael Eager wrote on Mon, Mar 24, 2008 at 07:04:40PM CET:
> I'm trying to include a fix for the recurring GCC_NO_EXECUTABLES problem.
> Refs:
> http://gcc.gnu.org/ml/gcc/2007-11/msg00790.html
> http://gcc.gnu.org/ml/gcc/2008-03/msg00515.html

FWIW, I was going to post a couple of patches for that eventually,
but I don't mind if you beat me to it.

> I get no errors when I run 'aclocal' but I do get two
> error messages when I run autoconf:
>
> $ autoconf
> configure.ac:177: error: possibly undefined macro: AC_LC_MESSAGES
>       If this token and others are legitimate, please use m4_pattern_allow.
>       See the Autoconf documentation.
> configure.ac:185: error: possibly undefined macro: AC_DEFINE

In which directory?  It looks like you forgot some -I options to
aclocal.  See ACLOCAL_AMFLAGS in the Makefile.am in the directory
where the respective configure.ac lives.

> /usr/share/aclocal contains lcmessage.m4.
>
> Any suggestions?   (BTW I'm running aclocal v. 1.10, autoconf v. 2.61)

You should have automake 1.9.6 and autoconf 2.59 in $PATH, for GCC, not
current versions.

Cheers,
Ralf


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]