This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

GNU GCC -m32 Problem?

Dear Mr. Randi J. Rost, et al.:

   I have a copy of your book entitled, OpenGL Shading Language,
Second  Edition, T 385 R665 2006 MAIN, UT Austin, and learned
that you have also worked with Motif.
   I have had a problem getting my "long double" version of
XEphem 3.7.2 to build under Red Hat Linux Fedora 7, x86_64
on an AMD Athlon 64 X2 Dual-Core Processor 5600+ based
   It builds OK under Red Hat Linux Fedora Core 6 on a Celeron
based 32-bit computer.  I could then bring the 32-bit application
executable to the 64-bit PC, and it worked fine also.
   However, I could not get it to build (using make) on the 64-bit PC,
even when I had specified ~ gcc -m32 . . ., using the latest GNU
GCC Compiler Collection (i.e., gcc-4.1.2-33.x86_64.rpm, et caetera,
installed).  Also, when I tried a simple C program - NO Motif at all
involved - I got compile error messages related to ~ stdlib.h, ~ 32 bit
stub missing, I seem to recall, for, I'm not at home now.
   I obviously would like to be able to also build on my 64-bit PC,
as well as develop and run in that environment entirely.
   Any assistance would be most gratefully appreciated.
   Tempus fugit et ad augusta per angusta.

                  Nil desparare (Gauss),

                  Joseph Roy D. North
                  Le        Roi  Du Nord
                  3220 Duval Road, Apt. 1110
                  Austin, TX 78759-3524, USA

Scientia est Potentia!

I Prefer Pi (a palindrome)!

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]