This is the mail archive of the gcc@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Bootstrap broken on mips-sgi-irix6.5


Hi there,

Mainline currently doesn't bootstrap on mips-sgi-irix6.5 due to an ICE
while compiling mips-sgi-irix6.5/64/libgcc/_powitf2.o at stage 1. This
happens, afaict, with any use of the TF mode with either -mabi=64 or
-mabi=n32:

$ cat foo.i
void __powitf2 (float x __attribute__ ((mode (TF)))) {}
$ /usr/people/francois/devel/ibin/./gcc/cc1 -fpreprocessed foo.i -quiet
zsh: segmentation fault  /usr/people/francois/devel/ibin/./gcc/cc1
-fpreprocessed foo.i -quiet

The backtrace for the segfault is:

Program received signal SIGSEGV, Segmentation fault.
0x104d7d50 in reg_classes_intersect_p (c1=32, c2=MD0_REG)
    at ../../trunk/gcc/regclass.c:2481
2481    {
(gdb) where
#0  0x104d7d50 in reg_classes_intersect_p (c1=32, c2=MD0_REG)
    at ../../trunk/gcc/regclass.c:2481
#1  0x102323cc in mips_cannot_change_mode_class (from=TFmode, to=DImode,
    class=FP_REGS) at ../../trunk/gcc/config/mips/mips.c:9346
#2  0x10823a38 in simplify_subreg (outermode=DImode, op=0x40b4c80,
    innermode=TFmode, byte=0) at ../../trunk/gcc/simplify-rtx.c:5014
#3  0x10824968 in simplify_gen_subreg (outermode=DImode, op=0x40b4c80,
    innermode=TFmode, byte=0) at ../../trunk/gcc/simplify-rtx.c:5211
#4  0x1027a700 in operand_subword (op=0x40b4c80, offset=0,
    validate_address=1, mode=TFmode) at ../../trunk/gcc/emit-rtl.c:1425
#5  0x1027a76c in operand_subword_force (op=0x40b4c80, offset=0, mode=TFmode)
    at ../../trunk/gcc/emit-rtl.c:1438
#6  0x10337484 in emit_move_multi_word (mode=TFmode, x=0x4c84200, y=0x40b4c80)
    at ../../trunk/gcc/expr.c:3275
#7  0x10337980 in emit_move_insn_1 (x=0x4c84200, y=0x40b4c80)
    at ../../trunk/gcc/expr.c:3347
#8  0x10337dc0 in emit_move_insn (x=0x4c84200, y=0x40b4c80)
    at ../../trunk/gcc/expr.c:3407
#9  0x102b4894 in copy_to_reg (x=0x40b4c80) at ../../trunk/gcc/explow.c:617
#10 0x1027a7cc in operand_subword_force (op=0x40b4c80, offset=0, mode=TFmode)
    at ../../trunk/gcc/emit-rtl.c:1448


I'm keeping the build tree so that I can investigate more if needed,
please tell me what to do. PR33635 has been opened to keep track of
this problem.

Thanks,
FX


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]