This is the mail archive of the
mailing list for the GCC project.
>>>>> Richard Sandiford writes:
Richard> So which of (1) and (2) from my message do think is best? Replace backend
Richard> uses with "reload_completed" when doing so is safe, or consistently replace
Richard> it with "reload_in_progress || reload_completed" throughout the backends?
I think the proposal is to get the semantics right first and then
fix the syntax, not just leave the long, cumbersome flag.
Creating a macro or alias could lead to confusion and creates an
opportunity for divergence.
Once this initial find-and-replace substitution is done, I am sure
that we all will be able to agree on way to rationalize the flags, but we
do not need to make all of the changes simultaneously.