This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

_alloca problem on compling gcc for sunos4.1.1

Hi there,

I would appreciate some help.

I have an old Sparc Station here with SunOs 4.1.1 running on it. It has
an old Sun cc compiler.

Now I'm trying to compile some things for it and decided that I need a
modern gcc for this. So I started trying with egcs 1.1.2 and gcc 2.95.3.

So I tried to compile one, what it completely failed.

Then I got gcc 1.42 compiled. This worked. So at least I have a native
gcc now.

But still I am not able to get one of the more modern compiled.

It always ends like this:

Bootstrapping the compiler
make[1]: Entering directory `/home/probe/build-egcs-1.1.2/gcc'
make CC="gcc" libdir=/usr/local/lib LANGUAGES="c "
make[2]: Entering directory `/home/probe/build-egcs-1.1.2/gcc'
./gencodes /home/probe/egcs-1.1.2/gcc/config/sparc/ >
tmp-codes.h Undefined symbol: _alloca
make[2]: *** [s-codes] Error 127
make[2]: Leaving directory `/home/probe/build-egcs-1.1.2/gcc'
make[1]: *** [bootstrap] Error 2
make[1]: Leaving directory `/home/probe/build-egcs-1.1.2/gcc'
make: *** [bootstrap] Error 2

I know there is a bug in the sun alloca library, but I thought, I
avoided it.
Now I got gcc 2.5.8 compiled. And as stated in the README I installed
the stage2 compiler. So I thought no _alloca Problem anymore.

But it is still the same!

Can anybodt help me?

Many thanks,


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]