This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: libtool version

   Ah crud.  Nevermind -- the offending shell code is in libtool 1.4.x 
too.  I just didn't see it since it gets generated by libtool.m4 and 
some quoting crud.

   Guess I'll either have to fix the quoting or determine that Mac OS X's 
/bin/sh is busted.


On Sunday, May 19, 2002, at 06:02  PM, Timothy J. Wood wrote:

> On Sunday, May 19, 2002, at 03:48  PM, Alexandre Oliva wrote:
>> On May 19, 2002, "Timothy J. Wood" <> wrote:
>>>    Is there any big reason to not upgrade gcc to use the latest
>>> libtool release?
>> The version in GCC is actually newer than libtool 1.4.x; it's an old
>> snapshot of the CVS tree that will eventually become libtool 1.5 (/me
>> wonders if 1.5 is out and I didn't notice :-), back from when it still
>> didn't require autoconf 2.5x.
>   The problem is in's definition of archive_expsym_cmds or 
> the quoting of same that happens when it is written into the libtool 
> script (this is when we're targeting MinGW, so it's all the dlltool 
> crud).  When that copy of libtool is run I get a bunch of errors.
>   Unfortunately the quoting is arcane enough that I've not had any luck 
> fixing it.
>   I tried installing the lastest stable libtool, libtoolizing gcc and 
> libobjc and had no luck.  The ltconfig script appears to get run from 
> the custom libtool.m4 -- but I tried linking that to the updated 
> version from libtool and STILL got the stupid quoting problems 
> (although I'm rerunning my build from clean now to see if stuff just 
> got left around)
> -tim

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]