This is the mail archive of the gcc@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Still failing to bootstrap on Solaris (CONFIG_SHELL doesn't help)


[ assertion that java is not on by default on Solaris ]

Rainer Orth writes:
> It used to be up to solaris 2.7, and disabled for 2.8 in the toplevel
> configure.in.  This has changed, though: now it's on by default for all
> releases, with a check which bails out if libgcj.la is present in $libdir.
> This check is for sparc-*-solaris2.8 only at the moment.  The new reports
> indicate that this problem occurs at least with some ld patchlevels on
> solaris 2.7.  I've just verified that it happens with the latest solaris
> 2.6 (107733-10) and 2.5.1 (103627-15) ld patches as well.

> So the safest approach seems to be to match *-*-solaris2* there to
> accomodate all of sparc, sparcv9 and i?86.

Sounds good.  The installation instructions should also be patched to
indicate that the Solaris user should remove any previously-installed libgcj
files before trying to build Java.



Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]