This is the mail archive of the gcc@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: bootstrap problem on sparc-sun-solaris2.7: libtool configure failed


On Fri, Apr 26, 2002 at 01:37:14PM +0100, Rupert Wood wrote:
> Joe Buck wrote:
> 
> > updating cache ../config.cache
> > loading cache ../config.cache within ltconfig
> > configure: error: libtool configure failed
> 
> This problem came up last year:
> 
>     http://gcc.gnu.org/ml/gcc/2001-04/threads.html#00423
> 
> (Please excuse my old muddled posts.) I think it's a bug in Sun's
> /bin/sh - you get exactly the same behaviour on i686-pc-solaris2.7.

Yep.  Must set CONFIG_SHELL=/bin/ksh when configuring.


> I thought someone put a workaround in place to use another shell (one of
> the kshes?) instead of /bin/sh when building on Solaris2.7 - and it
> certainly worked for a while - but I can't find any reference to that
> now. Sorry.

For some strange reason, this is still not the default when configuring
under Solaris.  It is, however, documented in the platform-specific
installation instructions.


Phil

-- 
If ye love wealth greater than liberty, the tranquility of servitude greater
than the animating contest for freedom, go home and leave us in peace.  We seek
not your counsel, nor your arms.  Crouch down and lick the hand that feeds you;
and may posterity forget that ye were our countrymen.            - Samuel Adams


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]