This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Successful Build of GCC 3.0.4

I just concluded a successful build of gcc-3.0.4 on my Redhat 6.2 system 
running kernel
2.2.14-5.0 and glibc-2.2.5.  I have had two problems so far as a result 
of this install.  First, after
installing glibc-2.2.5 I downloaded and installed XFree86 4.2.0 which 
requires glibc-2.2 or
greater (this was the main reason I chose to upgrade my glibc from 2.1 
to 2.2). The XFree86
install went fine, but when I tried to upgrade the linux drivers for my 
nvidia TNT2 M64
card to the latest version, I received an error message that said 
"failure due to the kernel
having been built with a different version of gcc/glibc than I was 
attempting to use to build
the drivers with."  Guess my next task is to upgrade my kernel with the 
installed gcc/glibc.
Second, I am receiving an error every time I activate Netscape 6.2 which 
I also just downloaded and installed.  This error says:

Gdk-WARNING **: locale not supported by C library

I also got this identical error when trying to install the latest Ximian 
Gnome after
downloading the installer program from their website.  I have sent a 
request for help
on this to the gnu glibc help line via email.  Maybe I didn't do 
something right when
I built glibc-2.2.5.  At any rate, I am currently compiling the latest 
version of Trolltech's
qt library which I downloaded from KDE.  Everything has gone ok so far.

# gcc -v
Reading specs from /usr/lib/gcc-lib/i686-pc-linux-gnu/3.0.4/specs
Configured with: ../gcc-3.0.4/configure --prefix=/usr --enable-shared 
Thread model: posix
gcc version 3.0.4

Jeff Stephens

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]