This is the mail archive of the gcc@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: ICE in change_address at emit_rtl.c


    If you increase the likely hood that the compiler will just work in
    the face of changing code, and random maintenance and decrease the
    maintenance code, and make the code easier to read and understand,
    then you gained more, than just renaming it, you've improved it.

Of course, but I'm not convinced this will happen.

    It is reasonable to find a way to `improve' SAVE_EXPR.  Check out
    UNSAVE_EXPR, and the `grossness' of it.  It is truely worth
    eliminating by design.  Unfortunately to get rid of it, you need to
    revamp SAVE_EXPR.

But those things are there because there's a semantic need for that
processing.  If you eliminate SAVE_EXPR, you have to replace it with
something that's similarly 'gross'.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]