This is the mail archive of the
mailing list for the GCC project.
Re: ICE in change_address at emit_rtl.c
- From: mike stump <mrs at windriver dot com>
- To: kenner at vlsi1 dot ultra dot nyu dot edu, neil at daikokuya dot demon dot co dot uk
- Cc: gcc at gcc dot gnu dot org
- Date: Mon, 26 Nov 2001 13:29:00 -0800 (PST)
- Subject: Re: ICE in change_address at emit_rtl.c
> Date: Sun, 25 Nov 01 09:23:28 EST
> From: email@example.com (Richard Kenner)
> To: firstname.lastname@example.org
> Cc: email@example.com
> And why can't you look inside a temporary the same way you look inside
> a SAVE_EXPR?
> Right now we have no mechanism for doing so.
> However, my question is what do we gain by removing SAVE_EXPR if we add
> temporaries that have exactly the same semantics? If you do everything
> that SAVE_EXPR can do, all you've done is renamed it!
If you increase the likely hood that the compiler will just work in
the face of changing code, and random maintenance and decrease the
maintenance code, and make the code easier to read and understand,
then you gained more, than just renaming it, you've improved it.
It is reasonable to find a way to `improve' SAVE_EXPR. Check out
UNSAVE_EXPR, and the `grossness' of it. It is truely worth
eliminating by design. Unfortunately to get rid of it, you need to