This is the mail archive of the
mailing list for the GCC project.
Re: ICE in change_address at emit_rtl.c
- From: Mark Mitchell <mark at codesourcery dot com>
- To: Neil Booth <neil at daikokuya dot demon dot co dot uk>, Gabriel Dos Reis <gdr at codesourcery dot com>
- Cc: "gcc at gcc dot gnu dot org" <gcc at gcc dot gnu dot org>
- Date: Sat, 24 Nov 2001 17:11:32 -0800
- Subject: Re: ICE in change_address at emit_rtl.c
--On Saturday, November 24, 2001 11:02:56 PM +0000 Neil Booth
> Gabriel Dos Reis wrote:-
>> What worries is the alternative he's proposing. My personnal view is
>> to have ERROR_MARK_XXX for TYPE, DECL and such in order to enhance
>> the tree type system and maintainability.
> Changing tack a little now, but still on the topic of violent changes
> to improve readability 8-)
> I've often wondered whether we might do better type-wise to actually
> use separate types, and refer to them as separate types
There is no question that this would be better. Other major front
ends use this approach, with considerable success.
Mark Mitchell email@example.com
CodeSourcery, LLC http://www.codesourcery.com