This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: [Ada]

> __get_errno __gl_exception_tracebacks __gl_locking_policy
> __gl_main_priority __gl_queuing_policy __gl_task_dispatching_policy
> __gl_time_slice_val __gl_unreserve_all_interrupts __gl_wc_encoding
> __set_errno _gnat_builtin_longjmp c_fileno c_stderr c_stdin c_stdout
> get_char get_int getc_immediate getc_immediate_common
> getc_immediate_nowait gnat_argc gnat_argv gnat_envp gnat_exit_status
> gnat_time mode_append_binary mode_append_binary_plus mode_append_text
> mode_append_text_plus mode_read_binary mode_read_binary_plus
> mode_read_text mode_read_text_plus mode_write_binary
> mode_write_binary_plus mode_write_text mode_write_text_plus
> null_function put_char put_char_stderr put_int put_int_stderr
> seek_end_function seek_set_function
> I guess at least the functions without any 'gnat' string in the name
> should be renamed.

Most of them should actually be marked as static, e.g mode_write* rather
than renamed.

For most of the remaining ones, this might break assumptions on existing
code (even if external users should not rely on these variables), in 
particular for gnat_argc and gnat_argv, so this is not such a trivial
change to do.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]