This is the mail archive of the gcc@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

3.0.2 on sol x86


  I know I asked this before and was indeed offered some tips...but they 
did not work.

I have built 3.0 and 3.0.1 on Sol8 x86 with no trouble... I cannot build 3.0.2!

/_subvdi3.o libgcc/./_mulvsi3.o libgcc/./_mulvdi3.o libgcc/./_negvsi2.o 
libgcc/./_negvdi2.o libgcc/./_ctors.o libgcc/./unwind-dw2.o 
libgcc/./unwind-dw2-fde.o libgcc/./unwind-sjlj.o -lc && rm -f libgcc_s.so.1 
&& ln -s libgcc_s.so libgcc_s.so.1
/usr/local/i386-pc-solaris2.8/bin/ld:libgcc.map: file format not 
recognized; treating as linker script
/usr/local/i386-pc-solaris2.8/bin/ld:libgcc.map:1: parse error
collect2: ld returned 1 exit status
make[3]: *** [libgcc_s.so] Error 1
make[3]: Leaving directory `/junk/gcc-3.0.2/test/gcc'
make[2]: *** [libgcc.a] Error 2
make[2]: Leaving directory `/junk/gcc-3.0.2/test/gcc'
make[1]: *** [stage1_build] Error 2
make[1]: Leaving directory `/junk/gcc-3.0.2/test/gcc'
make: *** [bootstrap] Error 2

..the configure runs fine and I did not build in the src directory..I 
created a dir called 'test' and ran from there....Still no luck.

I tried the 'ld' from GNU binutils and my SUN 'ld' and no difference.

I need some assistance in figuring out how to fix this?

TIA!





-J.D. Bronson
Aurora Health Care
Information Services
"Death before downtime"


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]