This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: Alpha GNU/Linux

>> Should that be changed to 

>>   You must install binutils 2.10 (or newer) to build GCC.

> Yeah.  I have zero interest in conditionalizing the dwarf2 support.

I do agree with your position.  But I want to make sure we inform the
Alpha user population of the best information we know.

This might be a local port issue (i.e. I don't know if it affects
Alpha GNU/Linux as well nor can I test it myself at the moment) which
I just learned of today, thus I haven't reported it yet, but:

I found that GNU ld version 2.10.1 and/or GNU assembler version 2.10.1
as shipped with FreeBSD [45] doesn't work with g++ (prerelease) 3.0
very well (all dejagnu-built executables core dump).  However,
binutils 2.11.90 built at or around 2001-03-27 does work fine with the
exception of the outstanding EH issues on alpha (which may have been
fixed at the time of this writing).

Loren J. Rittle
Senior Staff Software Engineer, Distributed Object Technology Lab
Networks and Infrastructure Research Lab (IL02/2240), Motorola Labs, KeyID: 2048/ADCE34A5, FDC0292446937F2A240BC07D42763672

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]