This is the mail archive of the gcc-prs@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

optimization/7897: gcc3.2 fails building kdeaddons when using the -march=pentium4 flag


>Number:         7897
>Category:       optimization
>Synopsis:       gcc3.2 fails building kdeaddons when using the -march=pentium4 flag
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    unassigned
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Sep 12 11:36:01 PDT 2002
>Closed-Date:
>Last-Modified:
>Originator:     Mark Hillary
>Release:        3.2
>Organization:
>Environment:
Configured with: /var/tmp/portage/gcc-3.2-r1/work/gcc-3.2/configure
--prefix=/usr --mandir=/usr/share/man -infodir=/usr/share/info --enable-shared
--host=i686-pc-linux-gnu --build=i686-pc-linux-gnu --target=i686-pc-gnu
--with-system-zlib -enable-languages=c,c++,ada,f77,abjc,java
--enable-threads=posix --enable-long-long --disable-checking
--enable-cstdio=stdio --enable-clocale=generic --enable-__cxa_atexit
--enable-version-specific-runtime-libs
--withgxx-include-dir=/ust/include/g++-v32 --with-local-prefix=/usr/local
--enable-shared --enable0nls --without-included-gettext
Thread model: posix
gcc version 3.2
CFLAGS=-march=pentium4 -O3 -pipe
CXXFLAGS=-march=pentium4 -O3 -pipe

Info from /proc/cpuinfo
cpu family	:15
model		:2
model name	:Intel(R) Pentium(R) 4 Mobile CPU 1.60Ghz
stepping	:4
>Description:
kdeaddons/noatun-plugins/tyler/compute.c failes to build using the -march=pentium4 flag

i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. _I../.. -I/usr/kde/3/include
-I/usr/qt/3/include -I/usr/X11R6/include -I/usr/nclude/SDL -D_REENTRANT
-DQT_THREAD_SUPPORT -D_REENTRANT -DNDEBUG -O2 -march=pentium4 -O3 -pipe -c `test -f compute.c
!! echo ' ./' `compute.c
compute.c: In function `generate_sector':
compute.c:175: unable to find a register to spill in class 'FLOAT_REGS'
compute.c:175: this is the insn:
(insn 187 184 189 (set (reg:DF 9 st(1) [117])
		(float_extend:DF (subreg:SF (reg/v:DI rxmm0 [82]) 0))) 133
{*extendsfdf2_1} (nil)
	(nil))
compute.c:175: confused by earlier errors, bailing out
make: *** [compute.o] Error 1

I have had this confirmed by one other person (sorry hes the only other person I know with a p4), same result also have tried with the -O2 flag instead of the -O3 flag
>How-To-Repeat:
Build kdeaddons on a P4 with -march=pentium4
>Fix:
Build with out -march=pentium4 or build with the pentium4 flag but add -mno-sse2 
>Release-Note:
>Audit-Trail:
>Unformatted:


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]