This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: List of typos.


Ondrej Bilka schrieb:

http://kam.mff.cuni.cz/~ondra/gcc_misspell.patch

This is wrong:

@@ -10834,7 +10834,7 @@ avr_convert_to_type (tree type, tree expr)
    XOP[2]  # Bytes to copy

    Return TRUE  if the expansion is accomplished.
-   Return FALSE if the operand compination is not supported.  */
+   Return FALSE if the operand compilation is not supported.  */

Should be "combination" not "compilation".


index 406617f..c7a7f7b 100644
--- a/gcc/config/frv/frv-opts.h
+++ b/gcc/config/frv/frv-opts.h
@@ -1,4 +1,4 @@
-/* Frv option-handling defitions.
+/* Frv option-handling deviations.

Should be "definitions" instead of "deviations".


-/* Expand SYMBOL into its corresponding far-addresse symbol.
+/* Expand SYMBOL into its corresponding far-addressee symbol.

Is this correct or should be "far-address"?


@@ -5336,7 +5336,7 @@ pa_print_operand (FILE *file, rtx x, int code)
 		   && GET_CODE (XEXP (XEXP (x, 0), 1)) == REG)
 	    {
 	      /* Because the REG_POINTER flag can get lost during reload,
-		 pa_legitimate_address_p canonicalizes the order of the
+		 pa_legitimate_address_p canonizes the order of the

I am not sure about this one and many others. "canonicalize" sounds ok to me, so does "canonicalization". "canonize" sounds odd to me. For example the following which should change none or both:

-/* Canonicalize the filename NAME by canonicalizing directory
+/* Canonicalize the filename NAME by canonizing directory

-   * Unique vinsn derivates from CALL, ASM, JUMP (for a while) and other
+   * Unique vinsn derivatives from CALL, ASM, JUMP (for a while) and other

Shouldn't this be "derives"?


-      /* Merge c_expres found or unify live register sets from different
+      /* Merge c_express found or unify live register sets from different

Some lines above in sel-sched.c there is "C_EXPRes". Again, change none or both (none seems fine here):


-  /* Test exponentials and their signs.  A buggy lexer is more likely
+  /* Test exponential and their signs.  A buggy lexer is more likely

Should both be plural or singular. "exponents" sounds good to me.


-   Roger Sayle <...@eyesopen.com>
+   Roger Sayle <...@eyes open.com>

Don't change email addresses!


Johann


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]